Bug 1261504 - mouse scroll does not work on dialog boxes (save, open, etc) with the new overlay scroll bars
mouse scroll does not work on dialog boxes (save, open, etc) with the new ove...
Status: CLOSED DUPLICATE of bug 1258236
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 09:20 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-13 09:57:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2015-09-09 09:20:14 EDT
Description of problem:
The new overlay scroll bars used in the save/open dialog boxes cannot be scrolled with a mouse scroll wheel. You need to explicitly select the scroll bar and drag the indicator to view contents.

This is a regression in the behavior of the mouse scroll wheel and the implementation of the overlay scroll bars.

Version-Release number of selected component (if applicable):
Fedora 23 - alpha

How reproducible:


Steps to Reproduce:
1. Open Firefox
2. Invoke the open or save dialog and go to a directory with a large number of entries that don't fit into the default dialog box
3. Use mouse scroll wheel to scroill thru the directory listing

Actual results:

Fails to scroll always


Expected results:


Entries should scroll.



Additional info:

LibreOffice which implements its own dialg boxes does not suffer from this issue
Comment 1 Marek Kašík 2015-09-09 09:36:53 EDT
This dialog comes from gtk3 so I'm reassigning this bug there.
Btw, I've tried to reproduce it with F23 alpha Live image but it works for me.
Comment 2 Benjamin Tissoires 2015-09-13 09:57:43 EDT

*** This bug has been marked as a duplicate of bug 1258236 ***

Note You need to log in before you can comment on or make changes to this bug.