Bug 1258302 - default block_migration_flag should not include VIR_MIGRATE_TUNNELLED [NEEDINFO]
default block_migration_flag should not include VIR_MIGRATE_TUNNELLED
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Prasanth Anbalagan
: Triaged
Depends On: 1221776 1267598
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 22:58 EDT by August Simonelli
Modified: 2016-11-14 15:47 EST (History)
8 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.12-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 10:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
emacchi: needinfo? (jcoufal)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 286584 None None None 2016-03-01 08:27 EST

  None (edit)
Description August Simonelli 2015-08-30 22:58:59 EDT
Description of problem:
On a basic deployment of OSP7 with Director nova.conf on the compute nodes sets the block_migration_flag to block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED, VIR_MIGRATE_NON_SHARED_INC
When trying block migration this leads to the error:
 Live Migration failure: internal error: unable to execute QEMU command ’migrate’: this feature or command is not currently supported
in the nova compute logs.
Removing VIR_MIGRATE_TUNNELLED as per https://bugzilla.redhat.com/show_bug.cgi?id=1211457 solves the issue. But for a default install it would be easier if it wasn't there as it's not correct.

Version-Release number of selected component (if applicable):


How reproducible:
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED, VIR_MIGRATE_NON_SHARED_INC in nova.conf
and run nova live-migration --block-migrate blockmig1 overcloud-compute-0.localdomain

Steps to Reproduce:
1. block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED, VIR_MIGRATE_NON_SHARED_INC
2. nova live-migration --block-migrate blockmig1 overcloud-compute-0.localdomain

3.

Actual results:
Migration fails with  Live Migration failure: internal error: unable to execute QEMU command ’migrate’: this feature or command is not currently supported
in the nova compute logs.

Expected results:
Migration succeeds.

Additional info:
Comment 4 Emilien Macchi 2015-09-14 12:24:36 EDT
We first need to support Nova migration, defined by https://bugzilla.redhat.com/show_bug.cgi?id=1221776

Until 1221776 is solved, neither resize or bloc migration would work.
Comment 5 Emilien Macchi 2016-01-07 14:10:53 EST
I might be wrong but AFIK there is no workaround at this time (need to be verified). I asked for the blocker flag because to me it's a very critical thing that to be able to migrate a VM.
Operating VMs often require to evacuate compute nodes, so I think we should provide the feature in OSP8.

Feel free to disagree on the blocker thing, if we can ship OSP8 without live migration or if any workaround has been applied somewhere I've missed.
Comment 7 Emilien Macchi 2016-02-25 17:15:34 EST
since we don't deploy live migration support out of the box, I'm not sure patching this bug can be solved for GA.
Comment 8 Marius Cornea 2016-02-25 17:30:11 EST
Please check BZ#1301986 for Nova guys recommendation in regards to this issue.
Comment 9 Emilien Macchi 2016-03-01 07:58:29 EST
I unassigned the bug, regarding BZ#1301986, someone from Nova's team should handle this bug.
Comment 10 Emilien Macchi 2016-03-01 08:07:39 EST
Assigning the bug again, and working on it with nova folks.
Comment 11 James Slagle 2016-03-16 12:29:26 EDT
merged to stable/liberty, will build later today
Comment 13 Amit Ugol 2016-03-22 04:58:52 EDT
from configuration point of view this looks ok, still need someone to test migration.
Comment 16 Prasanth Anbalagan 2016-04-12 21:58:12 EDT
Verified as follows,

************
VERSION
************

[stack@instack ~]$ rpm -qa openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-0.8.14-5.el7ost.noarch


*******
LOGS
*******

[heat-admin@overcloud-novacompute-0 ~]$ sudo grep "block_migration" /etc/nova/nova.conf 
#block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED, VIR_MIGRATE_NON_SHARED_INC
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_NON_SHARED_INC
[heat-admin@overcloud-novacompute-0 ~]$ 


[heat-admin@overcloud-novacompute-1 ~]$ sudo grep "block_migration" /etc/nova/nova.conf
#block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED, VIR_MIGRATE_NON_SHARED_INC
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_NON_SHARED_INC
[heat-admin@overcloud-novacompute-1 ~]$ 

[heat-admin@overcloud-novacompute-1 ~]$ nova list
+--------------------------------------+-----------+---------+------------+-------------+----------+
| ID                                   | Name      | Status  | Task State | Power State | Networks |
+--------------------------------------+-----------+---------+------------+-------------+----------+
| b9c1e141-beaa-4f12-acdf-705c9a4b7618 | numa-test | SHUTOFF | -          | Shutdown    |          |
| 6d4bd435-7040-49ba-92d5-7a1c6efddcc8 | vm2       | SHUTOFF | -          | Shutdown    |          |
| 73372d68-f5d2-43a2-86b0-2796666aea4a | vm3       | ACTIVE  | -          | Running     |          |
+--------------------------------------+-----------+---------+------------+-------------+----------+


[heat-admin@overcloud-novacompute-1 ~]$ 
[heat-admin@overcloud-novacompute-1 ~]$ nova host-list
+-------------------------------------+-------------+----------+
| host_name                           | service     | zone     |
+-------------------------------------+-------------+----------+
| overcloud-controller-0.localdomain  | scheduler   | internal |
| overcloud-controller-0.localdomain  | consoleauth | internal |
| overcloud-controller-0.localdomain  | conductor   | internal |
| overcloud-novacompute-1.localdomain | compute     | nova     |
| overcloud-novacompute-0.localdomain | compute     | nova     |
| overcloud-controller-0.localdomain  | cert        | internal |
+-------------------------------------+-------------+----------+
[heat-admin@overcloud-novacompute-1 ~]$ nova show vm3 | grep host
| OS-EXT-SRV-ATTR:host                 | overcloud-novacompute-0.localdomain                      |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | overcloud-novacompute-0.localdomain                      |
| hostId                               | 3e29a93ddf6b2523c52504366e87b28e12c01941bc17635cd4d7c666 |
[heat-admin@overcloud-novacompute-1 ~]$ 
[heat-admin@overcloud-novacompute-1 ~]$ 
[heat-admin@overcloud-novacompute-1 ~]$ nova live-migration --block-migrate vm3 overcloud-novacompute-1.localdomain
[heat-admin@overcloud-novacompute-1 ~]$ 
[heat-admin@overcloud-novacompute-1 ~]$ nova show vm3 | grep host
| OS-EXT-SRV-ATTR:host                 | overcloud-novacompute-1.localdomain                      |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | overcloud-novacompute-1.localdomain                      |
| hostId                               | 59a8043b41fe1eb2259658dd3ab4b536b8c8ccc3950b733624ed8075 |
[heat-admin@overcloud-novacompute-1 ~]$
Comment 18 errata-xmlrpc 2016-04-15 10:29:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0637.html

Note You need to log in before you can comment on or make changes to this bug.