Bug 1267598 - nova: when attempted 'nova resize' on setup with two compute nodes the instance switched to ERROR state.
nova: when attempted 'nova resize' on setup with two compute nodes the instan...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
x86_64 Linux
urgent Severity high
: z3
: 7.0 (Kilo)
Assigned To: Ollie Walsh
Archit Modi
: AutomationBlocker, InstallerIntegration, Reopened, TestOnly, ZStream
: 1221776 (view as bug list)
Depends On: 975014 1472723
Blocks: 1198809 1243520 1292532 1356451 1028186 1156010 1241501 1258302
  Show dependency treegraph
 
Reported: 2015-09-30 09:59 EDT by Mike Orazi
Modified: 2017-11-28 14:19 EST (History)
33 users (show)

See Also:
Fixed In Version: openstack-nova-2015.1.4-45.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 975014
: 1292532 (view as bug list)
Environment:
Last Closed: 2017-11-28 14:19:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 882143 None None None 2017-09-07 15:05 EDT

  None (edit)
Comment 2 Mike Orazi 2015-09-30 10:03:33 EDT
This is to ensure that nova resize works as expected when installation is driven by osp-director.
Comment 3 Mike Burns 2015-10-02 12:18:57 EDT
What we'd like to validate is that live migration and instance resize works after a director deployment.
Comment 4 arkady kanevsky 2015-10-02 12:23:46 EDT
Great that this is fixed in OSP?
Comment 5 Mike Orazi 2015-10-02 12:29:56 EDT
To clarify on this, we are requesting a retest of live migration and instance resize on director-based deployments.  There is a distinct possibility this will bounce back to development with specific issues that still need to be addressed but we want to re-validate the state of the functionality.
Comment 8 nlevinki 2015-12-16 04:26:49 EST
I marked this ticket as a blocker, if we try to deploy with 1000 compute nodes or more, customer will need to access each node and add the cert, this is unacceptable user experience. 
The issue is that nova@compute is trying to do a passwordless ssh into nova@controller.  However, nova@compute doesn't have a cert registered with nova@controller, so the passwordless login fails.
Comment 10 Jaromir Coufal 2015-12-16 04:55:31 EST
Given timeframe, this is not a blocker for 7.2, we can clearly document it and make sure to fix it in OSP8.
Comment 13 arkady kanevsky 2015-12-17 09:35:55 EST
Can you clarify where and which certs are needed?
Controller nodes need certs for each nova/compute node? Inverse?
All nova nodes need certs for all other nova nodes?
Undercloud need certs for all overcloud nodes?

Also it looks like we will need to split this BZ into two.
One for documentation for OSP7 and one for actual fix for OPS8/OSP8-d.
Comment 15 Mike Burns 2016-04-07 16:50:54 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 16 Karl Hastings 2016-07-22 13:57:42 EDT
Since this is deferred to OSP 10, I'm moving it to the delljs7.0 tracker.

Note that versions of this BZ exist for OSP 5, 975014, OSP 6 1028186, and OSP 7 1292532.

Should some of those BZ's be closed, or should this BZ have been left for OSP 8, and cloned for OSP 10?
Comment 17 Stephen Gordon 2016-11-14 15:47:32 EST
*** Bug 1221776 has been marked as a duplicate of this bug. ***
Comment 18 arkady kanevsky 2016-11-14 15:57:19 EST
So does this BZ makes it for OSP10 or not?
I am seeing a lot of pointers to various BZs that are either closed but not fixed or re-targeted to OSP11.
Comment 19 Stephen Gordon 2016-11-15 15:01:23 EST
(In reply to arkady kanevsky from comment #18)
> So does this BZ makes it for OSP10 or not?
> I am seeing a lot of pointers to various BZs that are either closed but not
> fixed or re-targeted to OSP11.

No, there are a number of issues in this area that the OOTB configuration does not currently support. The current documented workaround is the same as for live migration:

https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/single/director-installation-and-usage/#sect-Migrating_VMs_from_an_Overcloud_Compute_Node

Correcting this will require director/tripleo to handle this additional configuration (which in some environments will not be desired, so it will need to be togglable but default to on - not all operators accept the hosts having access to each other in this fashion), we are exploring what this will look like in Ocata.

I've left a 10.0.z flag for now in the hope that it might be backportable but this will depend on the resolution.
Comment 20 Sean Merrow 2017-03-15 13:06:57 EDT
Hi Steve, just checking in to see if there have been any further discussions on this since your November update in comment 19.
Comment 21 Stephen Gordon 2017-03-15 16:13:13 EDT
(In reply to Sean Merrow from comment #20)
> Hi Steve, just checking in to see if there have been any further discussions
> on this since your November update in comment 19.

We're still determining what whether we can offer an OOTB solution in 12, any opportunity for backport is obviously contingent on that, the priority is ensuring we have secure OOTB live migration - the cold migration setups (including resize) would need to be addressed after this. See also Bug # 1404294.
Comment 22 Audra Cooper 2017-04-14 09:34:25 EDT
I did a test of Nova Resize after setting up the ssh keys to the computes (following the instructions in the link noted in Comment 19), and it was successful with OSP10.
Comment 23 Audra Cooper 2017-07-14 09:51:09 EDT
This is now working OOTB in JS10.0.1.60 without the workaround of ssh keys.
Comment 25 Jon Schlueter 2017-11-14 20:58:53 EST
According to our records, this should be resolved by openstack-nova-2015.1.4-46.el7ost.  This build is available now.

Note You need to log in before you can comment on or make changes to this bug.