Bug 1258311 - trace xlator: Print write size also in trace_writev logs
trace xlator: Print write size also in trace_writev logs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: trace (Show other bugs)
mainline
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On:
Blocks: 1258411
  Show dependency treegraph
 
Reported: 2015-08-31 00:44 EDT by Krutika Dhananjay
Modified: 2016-06-16 09:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1258411 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:34:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-08-31 00:44:51 EDT
Description of problem:

Printing the total write size in the writev wind path of trace translator is useful for debugging issues in sharding.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-08-31 00:49:21 EDT
REVIEW: http://review.gluster.org/12053 (debug/trace: Print total write size in trace_writev) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2015-08-31 06:11:09 EDT
COMMIT: http://review.gluster.org/12053 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit fb8c9b38d8c42ecaf17df6e28c2a97d2cf13fb14
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Aug 31 09:56:02 2015 +0530

    debug/trace: Print total write size in trace_writev
    
    This is some information I find useful while debugging issues
    in shard translator.
    
    Change-Id: Ic35c34c2f52d27b3617fc722dabe558de2056b67
    BUG: 1258311
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12053
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:34:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.