Bug 1258411 - trace xlator: Print write size also in trace_writev logs
trace xlator: Print write size also in trace_writev logs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: trace (Show other bugs)
3.7.3
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On: 1258311
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 06:20 EDT by Krutika Dhananjay
Modified: 2015-10-14 06:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258311
Environment:
Last Closed: 2015-10-14 06:30:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-08-31 06:20:40 EDT
+++ This bug was initially created as a clone of Bug #1258311 +++

Description of problem:

Printing the total write size in the writev wind path of trace translator is useful for debugging issues in sharding.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-08-31 00:49:21 EDT ---

REVIEW: http://review.gluster.org/12053 (debug/trace: Print total write size in trace_writev) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Anand Avati on 2015-08-31 06:11:09 EDT ---

COMMIT: http://review.gluster.org/12053 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit fb8c9b38d8c42ecaf17df6e28c2a97d2cf13fb14
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Aug 31 09:56:02 2015 +0530

    debug/trace: Print total write size in trace_writev
    
    This is some information I find useful while debugging issues
    in shard translator.
    
    Change-Id: Ic35c34c2f52d27b3617fc722dabe558de2056b67
    BUG: 1258311
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12053
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 1 Anand Avati 2015-08-31 06:38:21 EDT
REVIEW: http://review.gluster.org/12065 (debug/trace: Print total write size in trace_writev) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2015-09-01 01:57:14 EDT
COMMIT: http://review.gluster.org/12065 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b60f931e8e2479d9a93e568b358feb24f52a864b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Aug 31 09:56:02 2015 +0530

    debug/trace: Print total write size in trace_writev
    
            Backport of: http://review.gluster.org/12053
    
    This is some information I find useful while debugging issues
    in shard translator.
    
    Change-Id: Ia33f656741750b4d5306599ea71ba1dc85bf311d
    BUG: 1258411
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12065
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Pranith Kumar K 2015-10-14 06:30:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Pranith Kumar K 2015-10-14 06:38:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.