Bug 1258321 - [RFE] Get token based kickstart url through API
[RFE] Get token based kickstart url through API
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature
: 1258320 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-31 01:47 EDT by Benjamin
Modified: 2018-06-14 14:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-14 14:02:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin 2015-08-31 01:47:21 EDT
Description of problem:
It is not possible to aquire the token based kickstart url. This can be needed if Cloud Suites are used where Satellite is "just" another tool for provisioning.

Version-Release number of selected component (if applicable):
6.1.1

How reproducible:
Not stated in the API Documentation.


Actual results:
No API Call documented/existing.

Expected results:
Have an API Call to query the token based kickstart URL for a system.

Additional info:
Comment 1 Ohad Levy 2015-08-31 08:49:31 EDT
can you please define the usage case a bit better?

What is just another tool? in that case is there a host entry? who creates it? etc.
Comment 2 Brad Buckingham 2015-09-22 13:23:50 EDT
*** Bug 1258320 has been marked as a duplicate of this bug. ***
Comment 3 Benjamin 2016-04-06 02:08:18 EDT
Hi,

the use case is to be able to acquire the kickstart URL of the system to be provisioned through API. At the moment a record is created with internal running code which creates a token to be able to fetch the kickstart file for a system. 

Maybe there are other existing methods to fetch the kickstart profile but those methods are not documented.

There are cases where customers would like to be able to automatically receive the kickstart url so they can use their own tftp server for example (automatically create the tftp boot record).
Comment 4 Bryan Kearney 2018-06-14 14:02:41 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.