Bug 1258397 - Should disable RHEV-M page after succeed setup Hosted Engine or provide a warning info
Should disable RHEV-M page after succeed setup Hosted Engine or provide a war...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-vdsm (Show other bugs)
3.5.4
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.8
: ---
Assigned To: Douglas Schilling Landgraf
wanghui
:
Depends On:
Blocks: 1316697
  Show dependency treegraph
 
Reported: 2015-08-31 05:43 EDT by wanghui
Modified: 2016-06-08 08:59 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-plugin-vdsm-0.6.1-6.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1316697 (view as bug list)
Environment:
Last Closed: 2016-06-08 08:59:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49052 master MERGED Disable engine registration if hosted engine is configured 2016-01-13 11:16 EST
oVirt gerrit 51800 ovirt-3.6 MERGED Disable engine registration if hosted engine is configured 2016-01-13 11:29 EST
oVirt gerrit 51825 master MERGED Check for Hosted Engine in self.application.plugins 2016-01-15 08:04 EST
oVirt gerrit 52370 ovirt-3.6 MERGED Check for Hosted Engine in self.application.plugins 2016-01-18 10:34 EST
oVirt gerrit 53324 master MERGED ui: Hide registration if HE was run 2016-03-10 14:27 EST
oVirt gerrit 54613 ovirt-3.6 MERGED ui: Hide registration if HE was run 2016-03-10 14:30 EST

  None (edit)
Description wanghui 2015-08-31 05:43:32 EDT
Description of problem:
It should disabled the RHEV-M page after succeed setup Hosted Engine or at least provide a warning info when people want to register to another rhevm.. Since rhevh can only be managed by one rhevm. So after setup Hosted Engine succeed, it should not allow to register to other RHEV-M or provide a warning info.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150827.1.el7ev
ovirt-node-3.2.3-20.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-18.0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.1-20150827.1.el7ev
2. Enabled network with dhcp type
3. Setup Hosted Engine with ova type
4. Check the RHEV-M page

Actual results:
1. RHEVM page still can be used as normal.

Expected results:
1. It should disabled the rhevm page in TUI or provide a warning infor when people want to register to another rhevm.

Additional info:
Comment 1 Fabian Deutsch 2015-09-01 05:55:05 EDT
I would not disable the page. But maybe we can set a flag or query a file if the setup completed successful and show that information.

But the solution also needs to handle failed attempts - IMO we should just ignore them, or hint that a cleanup is needed.
Comment 2 Ryan Barry 2015-09-01 20:40:07 EDT
For the RHEV-M page, it's easy to check the ha client to get enough information.

I would prefer not to handle any failed attempts of any kind in the TUI, including hinting that a cleanup is needed. There are many possible edge cases and failures, and reliably determining whether a cleanup is or isn't needed requires the TUI to know too much about the internals of ovirt-hosted-engine-setup.
Comment 4 wanghui 2016-02-03 02:56:27 EST
Hi Fabian,

I notice node already has disabled the RHEVM page after HE is registered. But due to the bug#1301486, the change has been reverted.

So this issue is still exists.

Here is my suggestion, since we can not just disabled the RHEVM page simply, we can provide a warning info when people want to register to another rhevm.

Thanks,
Hui Wang
Comment 8 Mike McCune 2016-03-28 19:24:30 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Fabian Deutsch 2016-03-30 10:49:43 EDT
Moving back to assigned, because the patches were incorrect and got reverted.
Comment 13 Fabian Deutsch 2016-06-08 08:59:11 EDT
There were no complaints so far on this item.

Closing this bug, please reopen if necessary.

However, this will be tackled in a different way in RHEV 4.

Note You need to log in before you can comment on or make changes to this bug.