Bug 1258577 - Create router with external network attached doesn't create router namespace
Create router with external network attached doesn't create router namespace
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
unspecified Severity medium
: rc
: 10.0 (Newton)
Assigned To: Jason E. Rist
Ido Ovadia
: Triaged
Depends On:
Blocks: 1303852
  Show dependency treegraph
 
Reported: 2015-08-31 12:46 EDT by Marius Cornea
Modified: 2016-12-14 10:15 EST (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-10.0.0-0.20161002185148.3252153.4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1303852 (view as bug list)
Environment:
Last Closed: 2016-12-14 10:15:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1535707 None None None 2016-02-15 00:05 EST
OpenStack gerrit 269605 None None None 2016-02-15 04:50 EST

  None (edit)
Description Marius Cornea 2015-08-31 12:46:56 EDT
Description of problem:
In Horizon when creating a router with an external network attached from the Create Router form a router namespace doesn't get created on the controller.

Version-Release number of selected component (if applicable):
openstack-dashboard-2015.1.0-10.el7ost.noarch
openstack-dashboard-theme-2015.1.0-10.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Go to Project-> Network -> Routers
2. Click Create Router
3. Input name, Admin state UP and select an External Network from the list 

Actual results:
Router gets created but no router namespace gets created on the controller. 

Expected results:
Router namespace gets created on the controller with an IP assigned from the selected external network.

Additional info:
If I don't select the external network in the Create Router form when I create it and attach it to the external network afterwards by using the set gateway button then the router namespace gets created ok.
Comment 3 Matthias Runge 2016-02-15 04:50:22 EST
Moving to rhos-9 since the patch contains a string change. String changes can not be backported in general, but there may be another translation for liberty.
Comment 4 Itxaka 2016-04-22 07:17:38 EDT
Patch was merged upstream, should be available on mitaka
Comment 6 Radomir Dopieralski 2016-10-20 07:30:19 EDT
This merged in Mitaka, it is available both in osp9 and osp10.
Comment 8 Ido Ovadia 2016-10-27 08:35:34 EDT
Verified
========
python-django-horizon-10.0.0-3.el7ost.noarch
puppet-horizon-9.4.0-1.el7ost.noarch
Comment 10 errata-xmlrpc 2016-12-14 10:15:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.