Bug 1258718 - [New] - Passive checks for services does not work as expected due to version mismatch of nsca server and client [NEEDINFO]
[New] - Passive checks for services does not work as expected due to version ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons (Show other bugs)
3.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 3.1.2
Assigned To: Ramesh N
Triveni Rao
: ZStream
Depends On: 1277082
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-09-01 01:58 EDT by RamaKasturi
Modified: 2016-05-16 00:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: nsca-2.9.1-4.1.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously, passive checks for services did not work as expected due to version mismatch of nsca server and client. As a consequence, nsca-client running on the Red Hat Enterprise Linux 7 Red Hat Gluster Storage nodes were unable to send the passive service status to the Nagios server running on Red Hat Enterprise Linux 6 Nodes. With this fix, the nsca package being shipped in Red Hat Enterprise Linux 6 Red Hat Gluster Storage is upgraded to nsca-2.9.1 version. Now, passive checks sent to the Nagios server (Red Hat Enterprise Linux 6) from Red Hat Enterprise Linux 7 Red Hat Gluster Storage nodes and Nagios monitoring works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:11:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rnachimu: needinfo? (divya)


Attachments (Terms of Use)
screen shot 1 (445.12 KB, image/png)
2015-11-20 05:57 EST, Triveni Rao
no flags Details

  None (edit)
Description RamaKasturi 2015-09-01 01:58:00 EDT
Description of problem:
In a deployment of RHSC+Nagios i.e where nagios server is installed on RHSC machine and RHGS nodes are based out of RHEL7.1, quorum status does not work as expected due to mismatch of nsca and nsca client.

Version-Release number of selected component (if applicable):
nagios-server-addons-0.2.2-1.el6rhs.noarch
gluster-nagios-addons-0.2.5-1.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install latest RHSC+Nagios
2. Add RHGS3.1 nodes based out of RHEL7.1
3. Run configure-gluser-nagios -c <clustername> -H <hostname>
4. Poweroff one of the nodes in cluster.

Actual results:
Due to mismatch of nsca and nsca client versions quorum plugin does not function correctly.

Expected results:
Quorum plugin should function correctly and display the appropriate status.

Additional info:
Comment 2 RamaKasturi 2015-09-02 07:59:55 EDT
Gluster Management, Gluster NFS, Quota, SMB, Brick Status, Self-Heal, Quorum does not work due to mismatch of nsca server and client versions.
Comment 4 Sahina Bose 2015-10-28 08:18:15 EDT
The RHEL 7 rhgs nodes have a higher version of nsca-client (nsca-client-2.9.1-11.2.el7rhgs.x86_64.rpm) . The nagios server running on RHEL 6 (console) has nsca version nsca-2.7.2-8.2.el6rhs.x86_64.rpm.

As per nagios mailing lists, the 2.9 version of nsca is not compatible with older servers due to change in packet size introduced in 2.9 (http://permalink.gmane.org/gmane.network.nagios.user/73111) 

However since the newer server (2.9) is compatible with older clients, one way to solve this is to increase the nsca version in RHEL 6 that we ship in RHSC.

Ramesh, what do you think?
Comment 5 Ramesh N 2015-11-03 07:03:35 EST
Latest NSCA package nsca-2.9.1-4 will fix this issue.
Comment 6 Triveni Rao 2015-11-20 05:56:48 EST
This bug is verified and found no issues:

Steps Followed:
1. Installed latest RHSC+Nagios 312
2. Add RHGS3.1.2 nodes based out of RHEL7.2
3. Run configure-gluser-nagios -c <clustername> -H <hostname>
4. Poweroff one of the nodes in cluster.
5. Cluster quorum showed proper messages.


On Gluster node version of nsca:

[root@dhcp37-127 ~]# rpm -qa | grep nsca
nsca-client-2.9.1-11.2.el7rhgs.x86_64
[root@dhcp37-127 ~]# 

On RHSC+Nagios node nsca version:

[root@dhcp37-142 yum.repos.d]# rpm -qa | grep nsca
nsca-2.9.1-4.1.el6rhs.x86_64
[root@dhcp37-142 yum.repos.d

Attached the screenshot taken during power off of one of the nodes.
Comment 7 Triveni Rao 2015-11-20 05:57 EST
Created attachment 1097100 [details]
screen shot 1
Comment 8 Divya 2016-02-02 03:54:46 EST
Ramesh,

Please review and sign-off the edited doc text.
Comment 9 Ramesh N 2016-02-02 05:25:32 EST
Doc text looks good technically correct but it looks really complex to understand because of more "Red Hat Enterprise Linux  6 Red Hat Gluster Storage" kind of sentence. Can we simplify?
Comment 11 errata-xmlrpc 2016-03-01 01:11:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.