Bug 125872 - USB Mouse Frozen
USB Mouse Frozen
Product: Fedora
Classification: Fedora
Component: system-config-mouse (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Depends On:
  Show dependency treegraph
Reported: 2004-06-12 19:21 EDT by sean adl
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-24 15:28:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/sysconfig/mouse (mjf) (111 bytes, text/plain)
2004-08-23 15:50 EDT, Michael Fischer
no flags Details
cat /proc/bus/input/devices (mjf) (453 bytes, text/plain)
2004-08-23 15:52 EDT, Michael Fischer
no flags Details
/etc/modprobe.conf (mjf) (831 bytes, text/plain)
2004-08-23 15:53 EDT, Michael Fischer
no flags Details

  None (edit)
Description sean adl 2004-06-12 19:21:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
The USB mouse attached to the computer worked fine when installing 
Fedora core 2, but does not work at all after its installed. it shows 
the cursor on screen when fedora boots up but remains frozen.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.start fedora
2.move mouse

Actual Results:  nothing happens. cursor remains in center of screen 
and doesnt respont to movement or  mouse clicks

Additional info:
Comment 1 Brent Fox 2004-06-18 10:51:44 EDT
Can you attach your /etc/sysconfig/mouse file?
Comment 2 Paul Nasrat 2004-08-11 06:10:18 EDT
Please attach /etc/sysconfig/mouse, the output of cat
/proc/bus/input/devices and grep usb /etc/modprobe.conf

USB mice are working for other people - including myself.
Comment 3 Michael Fischer 2004-08-23 15:49:35 EDT
I've experienced this exact same problem over the past 2-3 years on
several Dell computers with Logitech USB mice running several
different versions of Red Hat/Fedora linux, but it's generally been
intermittant.  If the mouse failed after a reboot, another reboot
would often fix the problem.  Sometimes it seemed to help to power off
completely before booting.

With FC2 and kernel (2.6.8-1.521) the problem is much worse so that
the mouse fails almost every time.  I just tried disabling legacy USB
support in the BIOS and the mouse came up the first time.  I don't
know yet if this has really fixed the problem or not.

Question: Is the correct module name "uhci-hcd" (with hyphen) or
"uhci_hcd" (with underscore)?  The module file name in
.../kernel/drivers/usb/host/ is uhci-hcd.ko, but the name given by
/sbin/lsmod is uhci_hcd. My modprobe.conf file contains the version
with the hyphen.

This problem might be related to bug 124378 (which is where I picked
up the idea of disabling legacy USB support).

I will attach my versions of /etc/sysconfig/mouse, the output of cat
/proc/bus/input/devices and grep usb /etc/modprobe.conf, although I am
not the original poster.
Comment 4 Michael Fischer 2004-08-23 15:50:30 EDT
Created attachment 102996 [details]
/etc/sysconfig/mouse (mjf)
Comment 5 Michael Fischer 2004-08-23 15:52:05 EDT
Created attachment 102997 [details]
cat /proc/bus/input/devices (mjf)
Comment 6 Michael Fischer 2004-08-23 15:53:21 EDT
Created attachment 102998 [details]
/etc/modprobe.conf (mjf)
Comment 7 Paul Nasrat 2004-09-06 03:29:36 EDT
Can the original reporter confirm that disabling legacy usb support in
their BIOS resolves this issue for them.  
Comment 8 Paul Nasrat 2004-11-24 15:28:00 EST
Closing due to lack of additional data from original reporter.  If the original
poster wants to confirm behaviour with bios changes, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.