Bug 1258740 - Opendnssec is installing files under /etc/tmpfiles.d/
Opendnssec is installing files under /etc/tmpfiles.d/
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: opendnssec (Show other bugs)
7.1
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Paul Wouters
Mohammad Rizwan
: EasyFix
: 1288425 (view as bug list)
Depends On:
Blocks: 1451431 1283777
  Show dependency treegraph
 
Reported: 2015-09-01 03:32 EDT by Morgan Weetman
Modified: 2017-08-01 08:50 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1180976
: 1451431 (view as bug list)
Environment:
Last Closed: 2017-08-01 08:50:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morgan Weetman 2015-09-01 03:32:21 EDT
+++ This bug was initially created as a clone of Bug #1180976 +++

Description of problem:
Package is installing files under /etc/tmpfiles.d/, according to 'man 5 tmpfiles.d':-

"Packages should install their configuration files in /usr/lib/tmpfiles.d. Files in /etc/tmpfiles.d are reserved for the local administrator, who may use this logic to override the configuration files installed by vendor packages"


Version-Release number of selected component (if applicable):
opendnssec-0:1.4.6-3.el7.x86_64

How reproducible:
repoquery --whatprovides "/etc/tmpfiles.d/*" | grep ^opendnssec

Actual results:
opendnssec-0:1.4.6-3.el7.x86_64

Expected results:
Should return nothing

Additional info:
Comment 2 Petr Spacek 2016-02-02 09:34:48 EST
*** Bug 1288425 has been marked as a duplicate of this bug. ***
Comment 9 Mohammad Rizwan 2017-06-01 03:25:39 EDT
verified.

version:
opendnssec-1.4.7-4.el7.x86_64

[root@ipa-master]# repoquery --whatprovides "/etc/tmpfiles.d/*" | grep ^opendnssec
[root@ipa-master]# 

[root@ipa-master]# ll /etc/tmpfiles.d/
total 8
-rw-r--r--. 1 root root 129 Jun  1 02:16 dirsrv-TESTRELM-TEST.conf
-rw-r--r--. 1 root root  72 Jun  1 02:18 ipa.conf
[root@ipa-master]# 
[root@ipa-master]# 
[root@ipa-master]# ll /usr/lib/tmpfiles.d/
total 116
-rw-r--r--. 1 root root   23 Jan 26 09:29 beakerlib.conf
-rw-r--r--. 1 root root  187 Sep  6  2016 certmonger.conf
-rw-r--r--. 1 root root   39 Mar 31 08:53 custodia.conf
-rw-r--r--. 1 root root  464 May 30 07:43 etc.conf
-rw-r--r--. 1 root root   77 May  9 11:18 httpd.conf
-rw-r--r--. 1 root root   39 May  3 06:34 initscripts.conf
-rw-r--r--. 1 root root   34 Apr 28 15:42 krb5-krb5kdc.conf
-rw-r--r--. 1 root root 1181 May 30 07:43 legacy.conf
-rw-r--r--. 1 root root   34 Mar 23 13:03 libselinux.conf
-r--r--r--. 1 root root   61 May 31 09:36 lvm2.conf
-rw-r--r--. 1 root root   32 May 22 09:31 named.conf
-rw-r--r--. 1 root root  191 Feb 23 06:30 opencryptoki.conf
-rw-r--r--. 1 root root   37 Apr 12 17:11 opendnssec.conf
-rw-r--r--. 1 root root  110 Jul 19  2016 pam.conf
-rw-r--r--. 1 root root   16 May  3 07:55 python.conf
-rw-r--r--. 1 root root   87 May 17 10:28 rpcbind.conf
-rw-r--r--. 1 root root   22 Mar 17 05:53 rpm.conf
-rw-r--r--. 1 root root   60 May 31 04:37 samba.conf
-rw-r--r--. 1 root root  228 May 30 07:43 sap.conf
-rw-r--r--. 1 root root  137 May 29 11:55 selinux-policy.conf
-rw-r--r--. 1 root root   33 May 30 10:35 subscription-manager.conf
-rw-r--r--. 1 root root  313 May 29 02:56 sudo.conf
-rw-r--r--. 1 root root   33 Aug 12  2015 svnserve.conf
-rw-r--r--. 1 root root 1662 May 30 07:43 systemd.conf
-rw-r--r--. 1 root root  496 May 30 07:43 systemd-nologin.conf
-rw-r--r--. 1 root root  638 May 30 07:43 tmp.conf
-rw-r--r--. 1 root root   56 Apr 11 10:05 tuned.conf
-rw-r--r--. 1 root root  563 May 30 07:43 var.conf
-rw-r--r--. 1 root root  623 May 30 07:43 x11.conf
[root@ipa-master]#
Comment 10 Abhijeet Kasurde 2017-06-01 06:34:54 EDT
Verified as per comment #9. Marking bz as verified.
Comment 11 errata-xmlrpc 2017-08-01 08:50:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2265

Note You need to log in before you can comment on or make changes to this bug.