Bug 1288425 - /etc/tmpfiles.d/opendnssec.conf shipped when /etc/tmpfiles.d is reserved for the local administrator
/etc/tmpfiles.d/opendnssec.conf shipped when /etc/tmpfiles.d is reserved for ...
Status: CLOSED DUPLICATE of bug 1258740
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: opendnssec (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Paul Wouters
Namita Soman
:
Depends On:
Blocks: 1283777
  Show dependency treegraph
 
Reported: 2015-12-04 02:49 EST by Jan Pazdziora
Modified: 2016-02-02 09:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 09:34:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-12-04 02:49:22 EST
Description of problem:

Package opendnssec ships /etc/tmpfiles.d/opendnssec.conf.

Man page tmpfiles.d(5) says:

       Files in /etc/tmpfiles.d override files with the same name in
       /usr/lib/tmpfiles.d and /run/tmpfiles.d. Files in /run/tmpfiles.d
       override files with the same name in /usr/lib/tmpfiles.d. Packages
       should install their configuration files in /usr/lib/tmpfiles.d. Files
       in /etc/tmpfiles.d are reserved for the local administrator, who may
       use this logic to override the configuration files installed by vendor
       packages.

Version-Release number of selected component (if applicable):

opendnssec-1.4.7-3.el7.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. yum install -y opendnssec
2. rpm -qf /etc/tmpfiles.d/opendnssec.conf

Actual results:

opendnssec-1.4.7-3.el7.x86_64

Expected results:

error: file /etc/tmpfiles.d/opendnssec.conf: No such file or directory

Additional info:

Shipping package content for /etc/tmpfiles.d complicates containerization when it's important to distinguish software and configuration/data, and when rpm upgrade mechanism for config files is not available because no rpm upgrade happen there.
Comment 1 Petr Spacek 2016-02-02 09:34:48 EST

*** This bug has been marked as a duplicate of bug 1258740 ***

Note You need to log in before you can comment on or make changes to this bug.