Bug 1258766 - quota test 'quota-nfs.t' fails spuriously
quota test 'quota-nfs.t' fails spuriously
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
:
Depends On:
Blocks: 1259652
  Show dependency treegraph
 
Reported: 2015-09-01 04:54 EDT by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1259652 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:34:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-09-01 04:54:37 EDT
Testcase ./tests/basic/quota-nfs.t fails spuriously

[02:25:45] ./tests/basic/quota-nfs.t .. 
not ok 18 Got "0Bytes" instead of "15.0MB"
Failed 1/22 subtests 


This could be because of NFS caching.
Comment 1 Anand Avati 2015-09-01 05:26:38 EDT
REVIEW: http://review.gluster.org/12075 (test: fix spurious failure from ./tests/basic/quota-nfs.t) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-09-01 07:00:20 EDT
REVIEW: http://review.gluster.org/12075 (test: fix spurious failure from ./tests/basic/quota-nfs.t) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-09-02 09:57:32 EDT
Test Comment
Comment 4 Vijay Bellur 2015-09-03 11:24:02 EDT
COMMIT: http://review.gluster.org/12075 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 76233f0cf43125a83b79de3ca5dc742fc9850cce
Author: vmallika <vmallika@redhat.com>
Date:   Tue Sep 1 14:21:43 2015 +0530

    test: fix spurious failure from ./tests/basic/quota-nfs.t
    
    Before checking for the quota usage,
    umount and mount NFS mountpoint to flush the NFS cached data.
    
    This test is fails on NetBSD, so marking the test as bad-test
    
    Change-Id: I1f30f5d9a919b3959c9f158366bd2f47569c8e03
    BUG: 1258766
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12075
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:34:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.