Bug 1259652 - quota test 'quota-nfs.t' fails spuriously
quota test 'quota-nfs.t' fails spuriously
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1258766
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 05:36 EDT by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258766
Environment:
Last Closed: 2015-10-14 06:29:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-09-03 05:36:38 EDT
+++ This bug was initially created as a clone of Bug #1258766 +++

Testcase ./tests/basic/quota-nfs.t fails spuriously

[02:25:45] ./tests/basic/quota-nfs.t .. 
not ok 18 Got "0Bytes" instead of "15.0MB"
Failed 1/22 subtests 


This could be because of NFS caching.

--- Additional comment from Anand Avati on 2015-09-01 05:26:38 EDT ---

REVIEW: http://review.gluster.org/12075 (test: fix spurious failure from ./tests/basic/quota-nfs.t) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-09-01 07:00:20 EDT ---

REVIEW: http://review.gluster.org/12075 (test: fix spurious failure from ./tests/basic/quota-nfs.t) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-02 09:57:32 EDT ---

Test Comment
Comment 1 Vijay Bellur 2015-09-03 05:39:21 EDT
REVIEW: http://review.gluster.org/12097 (test: fix spurious failure from ./tests/basic/quota-nfs.t) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Pranith Kumar K 2015-10-14 06:29:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 3 Pranith Kumar K 2015-10-14 06:38:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.