Bug 1258769 - libglusterfs: Pending - Porting log messages to new framework
libglusterfs: Pending - Porting log messages to new framework
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
3.7.3
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Mohamed Ashiq
:
Depends On: 1242211 1252836
Blocks: 1241957
  Show dependency treegraph
 
Reported: 2015-09-01 05:06 EDT by Mohamed Ashiq
Modified: 2015-10-14 06:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1252836
Environment:
Last Closed: 2015-10-14 06:29:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-09-01 05:06:25 EDT
+++ This bug was initially created as a clone of Bug #1252836 +++

+++ This bug was initially created as a clone of Bug #1242211 +++

Description of problem:
-----------------------
There are few instances of 'gf_log' and 'gf_log_callingfn' seen under libglusterfs
These instances needs to be ported to new logging framework

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS-3.1 Nightly ( glusterfs-3.7.1-8.el6rhs )


Expected results:
-----------------
All old log messages should be ported to new logging framework

--- Additional comment from SATHEESARAN on 2015-07-12 13:18:07 EDT ---

src/inode.c:  gf_log_callingfn (THIS->name, GF_LOG_WARNING,
src/inode.c-        "inode not found");

[satheesaran@dhcppc1 libglusterfs]$ grep -r "gf_log " src/logging.h -B1 -A1

int _gf_log (const char *domain, const char *file,
             const char *function, int32_t line, gf_loglevel_t level,
--
                FMT_WARN (fmt);                                         \
                _gf_log (dom, __FILE__, __FUNCTION__, __LINE__,         \
                         levl, ##fmt);                                  \
--
#define GF_LOG_OCCASIONALLY(var, args...) if (!(var++%GF_UNIVERSAL_ANSWER)) { \
                gf_log (args);                                          \
        }
--
#define GF_DEBUG(xl, format, args...)                           \
        gf_log ((xl)->name, GF_LOG_DEBUG, format, ##args)
#define GF_INFO(xl, format, args...)                            \
        gf_log ((xl)->name, GF_LOG_INFO, format, ##args)
#define GF_WARNING(xl, format, args...)                         \
        gf_log ((xl)->name, GF_LOG_WARNING, format, ##args)
#define GF_ERROR(xl, format, args...)                           \
        gf_log ((xl)->name, GF_LOG_ERROR, format, ##args)


--
src/xlator.c:  gf_log ("glusterfs", gf_log_get_loglevel(),
src/xlator.c-       "setting log level to %d (old-value=%d)",
--
src/xlator.c:  gf_log (this->name, gf_log_get_xl_loglevel (this),
src/xlator.c-        "setting log level to %d (old-value=%d)",
--
src/xlator.c:  gf_log (trav->name, gf_log_get_xl_loglevel (trav),
src/xlator.c-        "setting log level to %d (old-value=%d)",

src/unittest/log_mock.c:int _gf_log (const char *domain, const char *file,
src/unittest/log_mock.c-             const char *function, int32_t line, gf_loglevel_t level,

--
src/run.c:  gf_log_callingfn (dom, lvl, "%s: %s", msg, buf);
src/run.c-
--
src/timespec.c:        gf_log_callingfn ("timer", GF_LOG_TRACE, "%"GF_PRI_TIME".%09"GF_PRI_TIME,
src/timespec.c-                          ts->tv_sec, ts->tv_nsec);

--- Additional comment from Anand Avati on 2015-08-12 06:39:00 EDT ---

REVIEW: http://review.gluster.org/11896 (libglusterfs: Pending - Porting log messages to new framework) posted (#1) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-13 02:08:01 EDT ---

REVIEW: http://review.gluster.org/11896 (libglusterfs: Pending - Porting log messages to new framework) posted (#2) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 10:08:45 EDT ---

REVIEW: http://review.gluster.org/11896 (libglusterfs: Porting log messages to new framework) posted (#3) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-28 02:22:05 EDT ---

REVIEW: http://review.gluster.org/11896 (libglusterfs: Porting log messages to new framework) posted (#4) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-31 03:31:58 EDT ---

REVIEW: http://review.gluster.org/11896 (libglusterfs:Porting log messages to new framework) posted (#5) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-31 07:06:11 EDT ---

REVIEW: http://review.gluster.org/11896 (libglusterfs:Porting log messages to new framework) posted (#6) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 1 Anand Avati 2015-09-01 05:51:48 EDT
REVIEW: http://review.gluster.org/12076 (libglusterfs:Porting log messages to new framework) posted (#1) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 2 Vijay Bellur 2015-09-08 03:56:58 EDT
COMMIT: http://review.gluster.org/12076 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 5046fc8f267851b4ce530f8a3ba41d5ac5c9ea87
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Wed Aug 12 15:21:17 2015 +0530

    libglusterfs:Porting log messages to new framework
    
    	Backport of http://review.gluster.org/11896
    
    Cherry picked from 038dfe57cf0c5944b0392332dbf5a00bb1208150
    >Change-Id: I8625b7dc8941720cc7a864b8fddbcc7b4c485fcd
    >BUG: 1252836
    >Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    >Reviewed-on: http://review.gluster.org/11896
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    
    Change-Id: I8625b7dc8941720cc7a864b8fddbcc7b4c485fcd
    BUG: 1258769
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Reviewed-on: http://review.gluster.org/12076
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Pranith Kumar K 2015-10-14 06:29:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Pranith Kumar K 2015-10-14 06:38:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.