Bug 1258798 - bug-948686.t fails spuriously
bug-948686.t fails spuriously
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1258714 1282847
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 06:13 EDT by Atin Mukherjee
Modified: 2015-11-17 10:52 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258714
Environment:
Last Closed: 2015-10-14 06:30:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2015-09-01 06:13:56 EDT
+++ This bug was initially created as a clone of Bug #1258714 +++

Description of problem:

bug-948686.t intermittely ends up in a race in GlusterD where one thread deletes
a stale volume and on a volume start request a start is attempted on the same   object which might be freed up by the other thread. We are considering to use  refcounting mechanism while accessing volinfo objects to get rid of this problem
but that needs a significant amount of time in development. Till then adding
this test in bad_tests ()

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Intermittent

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-09-01 01:37:21 EDT ---

REVIEW: http://review.gluster.org/12070 (tests: add bug-948686.t to bad_tests) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Anand Avati on 2015-09-01 04:42:34 EDT ---

COMMIT: http://review.gluster.org/12070 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 99cd07c596f74b1ee8a88c4a43b37eb0921e5fe2
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Tue Sep 1 10:53:19 2015 +0530

    tests: add bug-948686.t to bad_tests
    
    bug-948686.t intermittely ends up in a race in GlusterD where one thread deletes
    a stale volume and on a volume start request a start is attempted on the same
    object which might be freed up by the other thread. We are considering to use
    refcounting mechanism while accessing volinfo objects to get rid of this problem
    but that needs a significant amount of time in development. Till then adding
    this test in bad_tests ()
    
    Change-Id: I3ddc025b07c47b17ea75554d5cc809a839365f10
    BUG: 1258714
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/12070
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 1 Anand Avati 2015-09-01 08:50:52 EDT
COMMIT: http://review.gluster.org/12077 committed in release-3.7 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 9c6f316389fe97db2a870a4d8cbee8430c33227d
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Tue Sep 1 10:53:19 2015 +0530

    tests: add bug-948686.t to bad_tests
    
    backport of http://review.gluster.org/#/c/12070/
    
    bug-948686.t intermittely ends up in a race in GlusterD where one thread deletes
    a stale volume and on a volume start request a start is attempted on the same
    object which might be freed up by the other thread. We are considering to use
    refcounting mechanism while accessing volinfo objects to get rid of this problem
    but that needs a significant amount of time in development. Till then adding
    this test in bad_tests ()
    
    Change-Id: I3ddc025b07c47b17ea75554d5cc809a839365f10
    BUG: 1258798
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/12070
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    (cherry picked from commit 99cd07c596f74b1ee8a88c4a43b37eb0921e5fe2)
    Reviewed-on: http://review.gluster.org/12077
Comment 2 Pranith Kumar K 2015-10-14 06:30:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 3 Pranith Kumar K 2015-10-14 06:38:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.