This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 125882 - Does not compile with CONFIG_SOFTWARE_SUSPEND/PMDISK enabled (undefined reference to `swsusp_pg_dir')
Does not compile with CONFIG_SOFTWARE_SUSPEND/PMDISK enabled (undefined refer...
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
http://linux.bkbits.net:8080/linux-2....
: EasyFix, Patch
: 125986 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-13 02:49 EDT by Aleksey Nogin
Modified: 2015-01-04 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 20:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A patch to arch/i386/mm/init.c that fixes this (762 bytes, text/plain)
2004-06-24 01:31 EDT, Aleksey Nogin
no flags Details
Corrected linux-2.6.0-4g4g.patch (128.58 KB, patch)
2004-11-25 01:32 EST, Aleksey Nogin
no flags Details | Diff
Difference between the original linux-2.6.0-4g4g.patch and the corrected one (3.66 KB, patch)
2004-11-25 01:34 EST, Aleksey Nogin
no flags Details | Diff

  None (edit)
Description Aleksey Nogin 2004-06-13 02:49:52 EDT
I've been using the pre-FC2 Raw Hide and FC2 kernels (including
2.6.5-1.358 2.6.5-1.351 2.6.5-1.346 2.6.5-1.339 2.6.5-1.332 and a
lange number of earlier ones) recompiled with CONFIG_SOFTWARE_SUSPEND
enabled without much problems. However when I try recompiling
2.6.6-1.427 with CONFIG_SOFTWARE_SUSPEND, I get:
  ...
  LD      .tmp_vmlinux1
arch/i386/power/built-in.o(.text+0x1a3): In function `do_magic':
: undefined reference to `swsusp_pg_dir'
make: *** [.tmp_vmlinux1] Exit 1

grep suggests that the only occurrence of swsusp_pg_dir in the sources
are:
./arch/i386/power/pmdisk.S:     movl $swsusp_pg_dir-__PAGE_OFFSET,%ecx
./arch/i386/power/swsusp.S:     movl $swsusp_pg_dir-__PAGE_OFFSET,%ecx

According to linux.bkbits.net, the "swsusp_pg_dir" first appeared in
swsusp.S and pmdisk.S as a result of the following patch:

http://linux.bkbits.net:8080/linux-2.5/cset@40b3691eO9MJaSUywupm4EydmK80Iw

But for some reason that patch is present in 2.6.6-1.427 only
partially - the arch/i386/mm/init.c part is missing!
Comment 1 Dave Jones 2004-06-15 17:43:51 EDT
*** Bug 125986 has been marked as a duplicate of this bug. ***
Comment 2 Aleksey Nogin 2004-06-24 00:38:13 EDT
Still there with 2.6.6-1.435
Comment 3 Aleksey Nogin 2004-06-24 01:31:05 EDT
Created attachment 101369 [details]
A patch to arch/i386/mm/init.c that fixes this

This is a patch based on
http://linux.bkbits.net:8080/linux-2.5/cset@40b3691eO9MJaSUywupm4EydmK80Iw
Comment 4 Sameh Attia 2004-07-03 01:34:19 EDT
Me too with 435.2.1
It also happens with Planet CCRMA 2.6.7-1.437.1.11.fc2.ccrma
Comment 5 Ted Kaczmarek 2004-07-18 09:39:43 EDT
Still happens with 2.6.7-1.492 as well.
Comment 6 Ted Kaczmarek 2004-07-18 09:55:49 EDT
Tested 2.6.7-1.492 with attachment (id=101369) and it does build the rpm.
Comment 7 Aleksey Nogin 2004-08-20 12:06:29 EDT
Still there with 2.6.8-1.521
Comment 8 Dan Morrill 2004-10-24 21:37:17 EDT
Still there with kernel-2.6.9-1.640 in FC3 test.  Patch (id=101369)
still applies cleanly and appears to get the build to work. (Haven't
booted it yet though.)
Comment 9 Barry K. Nathan 2004-11-13 09:14:39 EST
Still there with 2.6.9-1.667 in FC3 final release, but I haven't tried
the patch yet.
Comment 10 Dave Jones 2004-11-19 23:22:42 EST

*** This bug has been marked as a duplicate of 126342 ***
Comment 11 Aleksey Nogin 2004-11-20 18:26:04 EST
I disagree with this being duped against a generic "custom kernels" bug.  

This bug is about:
 1) Red Hat/Fedora introducing a problem that does not exist in
kernel.org kernels
 2) A problem for which a fix is very simple and a patch is attached
to this bug.
 3) A problem that affects quite a number of people (there are 4 "mee
too"s and one dup), that is readily reproducible and that existed for
quite a few version of Red Hat/Fedora - provided kernels.

P.S. It apperars that the linux-2.6.0-4g4g.patch is the one
responsible for this problem.
Comment 12 Dave Jones 2004-11-22 20:01:15 EST
too bad. its not something we support, hence not something we'll spend time on
fixing.


*** This bug has been marked as a duplicate of 126342 ***
Comment 13 Aleksey Nogin 2004-11-22 21:10:59 EST
> its not something we support, hence not something we'll spend time on
> fixing.

I am not asking you too - just asking to include a trivial patch
that's already attached here...
Comment 14 Aleksey Nogin 2004-11-25 01:32:12 EST
Created attachment 107451 [details]
Corrected linux-2.6.0-4g4g.patch

This is the corrected version of the linux-2.6.0-4g4g.patch. I took the
linux-2.6.0-4g4g.patch from 2.6.9-1.681_FC3 sources and updated the
arch/i386/mm/init.c portion of it.
Comment 15 Aleksey Nogin 2004-11-25 01:34:46 EST
Created attachment 107452 [details]
Difference between the original linux-2.6.0-4g4g.patch and the corrected one

Note that this is a "level 2 diff" (i.e. a diff between two diffs). It shows
the differences between the linux-2.6.0-4g4g.patch in 2.6.9-1.681_FC3 sources
and the one in attachment 107451 [details].

P.S. Who is the maintainer of linux-2.6.0-4g4g.patch? Is [s]he aware of this
bug?
Comment 16 Aleksey Nogin 2005-01-05 04:03:03 EST
As far as I can tell, this is finally fixed in 2.6.9-1.724_FC3.

Note You need to log in before you can comment on or make changes to this bug.