Bug 125986 - bug in pmdisk of kernel-sourcecode
bug in pmdisk of kernel-sourcecode
Status: CLOSED DUPLICATE of bug 125882
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 126079 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 16:32 EDT by Joe Winegarden
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Winegarden 2004-06-14 16:32:20 EDT
Description of problem:
There is a 'typo' on line 24 of arch/i386/power/pmdisk.S in the
newly-release kernel-sourcecode-2.6.6-1.435:
movl $swsusp_pg_dir-...
$swsusp_pg_dir is an unknown object, disallowing me to compile my own
kernel with PM_DISK included.
I changed this to match the same line in kerne-source-2.6.5-1.358:
$swapper_pg_dir-...
This allows make bzImage to complete successfully with PM_DISK
included. Suspend/Resume via pmdisk seems to work correctly with this
fix once new kernel is loaded.


Version-Release number of selected component (if applicable):
kernel-sourcecode-2.6.6-1.435

How reproducible:
Always, until modified as described.

Steps to Reproduce:
1. Modify kernel config to include software suspend (PM_DISK)
2. Attempt to make bzImage
3. Compilation fails with unknown object 'swsusp_pg_dir' error
  
Actual results:


Expected results:


Additional info:
Comment 1 Joe Winegarden 2004-06-15 16:35:48 EDT
*** Bug 126079 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2004-06-15 17:43:48 EDT

*** This bug has been marked as a duplicate of 125882 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.