Bug 1258887 - [RFE] Allow notification handling to be described in a declarative fashion
[RFE] Allow notification handling to be described in a declarative fashion
Status: CLOSED DUPLICATE of bug 1258888
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
Yurii Prokulevych
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 09:08 EDT by Eoghan Glynn
Modified: 2015-09-04 07:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 07:32:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eoghan Glynn 2015-09-01 09:08:03 EDT
Consuming new notifications, or selecting specific topics/exchanges, should not require explicit python code additions as it does currently in ceilometer.

Instead all this should be driven from a single source of configuration in an easily readable format such as YAML.

To facilitate ease of upgrades, if the configuration file is missing, we should fallback to the out-of-the-box defaults in-code.
Comment 3 Yurii Prokulevych 2015-09-04 07:32:22 EDT

*** This bug has been marked as a duplicate of bug 1258888 ***

Note You need to log in before you can comment on or make changes to this bug.