Bug 1258888 - [RFE] Allow notification handling to be described in a declarative fashion
Summary: [RFE] Allow notification handling to be described in a declarative fashion
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer   
(Show other bugs)
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 8.0 (Liberty)
Assignee: Eoghan Glynn
QA Contact: Yurii Prokulevych
URL: https://blueprints.launchpad.net/ceil...
Whiteboard: upstream_milestone_liberty-3 upstream...
Keywords: FutureFeature, OtherQA
: 1258887 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-01 13:08 UTC by Eoghan Glynn
Modified: 2016-04-07 21:05 UTC (History)
5 users (show)

Fixed In Version: openstack-ceilometer-5.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 21:05:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0603 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 Enhancement Advisory 2016-04-08 00:53:53 UTC

Description Eoghan Glynn 2015-09-01 13:08:14 UTC
Consuming new notifications, or selecting specific topics/exchanges, should not require explicit python code additions as it does currently in ceilometer.

Instead all this should be driven from a single source of configuration in an easily readable format such as YAML.

To facilitate ease of upgrades, if the configuration file is missing, we should fallback to the out-of-the-box defaults in-code.

Comment 3 Yurii Prokulevych 2015-09-04 11:32:22 UTC
*** Bug 1258887 has been marked as a duplicate of this bug. ***

Comment 4 Pradeep Kilambi 2015-09-09 17:33:12 UTC
The goal of this feature is to be able to define meters as part of a declarative yaml file without having to write notification handlers. Things to verify:

* Installation. Make sure the yaml file is deployed and accessible under /etc/ceilometer/meter.yaml and fallsback to ceilometer/meter/data/meter.yaml.

* Verify multi meter notifications

* Verify definitions which involve volume computation having an expression

* Verify definitions with combination strings 

* Validate error handling:
  - syntax handling
  - required fields in yaml (name, event_type, volume, type)
  - missing config
  - duplicate entries
  - types of meters

* By default, event meters with volume =1 are disabled, to enable these set store_notifications enabled and verify volume=1 meters and vice-versa.

* exchange control shouldnt change much.. just moved it to a central location

*  Overall we need to make sure the default meters in meters.yaml are generating samples as expected.

Please let me know if you need any clarification.

Comment 6 Yurii Prokulevych 2016-02-24 13:21:51 UTC
Verified according test plan in ceilometer*-5.0.2-2.el7ost.noarch

Comment 8 errata-xmlrpc 2016-04-07 21:05:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html


Note You need to log in before you can comment on or make changes to this bug.