Bug 125895 - parted: partitions in use
parted: partitions in use
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhel-sag (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
John Ha
http://www.redhat.com/docs/manuals/en...
:
Depends On:
Blocks: 123819 152485
  Show dependency treegraph
 
Reported: 2004-06-13 09:00 EDT by Andrew Martynov
Modified: 2014-08-04 18:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 15:14:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Martynov 2004-06-13 09:00:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
Chapter 5. Managing Disk Storage
said:
"Alternately, if the drive does not contain any partitions in use, you
can unmount them with the umount command and turn off all the swap
space on the hard drive with the swapoff  command."

As I understand if partition is mounted that mean what it is used.
So this partitions is "in use" state.

I suppose that it more correctly to write "any partitions with data in
use" here because here it is necessary to determine exactly usage of data.

Usage of swap space is not necessary to take into consideration
because it can affect only perfomance (not data loss in most cases)

So this paragraph, in my opinion, shoul looks as
"Alternately, if the drive does not contain any partitions with data
in use, you can unmount them with the umount command and turn off all
the swap space on the hard drive with the swapoff  command."

Version-Release number of selected component (if applicable):
rhel-sag(EN)-3-HTML-RHI (2003-07-25T17:10)

How reproducible:
Always

Steps to Reproduce:
1. open URL
http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/ch-disk-storage.html
2. look into fifth paragraph
3.
    

Additional info:
Comment 1 Andrius Benokraitis 2005-03-16 17:51:21 EST
I'd stipulate that "... system processes that use or lock the partition from
being unmounted" would be better than "data in use"

What do you think? :-)
Comment 2 Andrew Martynov 2005-03-17 05:11:43 EST
Yes, you are right. We should determine the process which use data and do
something to release data and umount partition.
Comment 3 Andrius Benokraitis 2005-03-17 12:55:51 EST
Great! I'll update the chapter accordingly. Expect to see the changes on or
about RHEL4 Update 1 timeframe in the SAG...

Thanks for your feedback! :-)
Comment 4 Andrius Benokraitis 2005-04-28 15:14:42 EDT
Adding to the RHEL4U1 version of the System Admin Guide.

Note You need to log in before you can comment on or make changes to this bug.