Bug 1258967 - Parameters in stack-show are not updated after a failed update
Parameters in stack-show are not updated after a failed update
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: z2
: 7.0 (Kilo)
Assigned To: Zane Bitter
Amit Ugol
: Triaged, ZStream
Depends On:
Blocks: 1255910 1263091
  Show dependency treegraph
 
Reported: 2015-09-01 11:42 EDT by Zane Bitter
Modified: 2016-04-26 09:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-heat-2015.1.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, when a stack update failed the Orchestration service continued to store the old parameter values instead of the ones supplied with the failed update attempt. Whenever this occurred, the Orchestration service incorrectly showed the parameter values from the last successful update. If the parameter schema of the template changed, attempting to show the failed stack sometimes resulted in an error. With this release, the Orchestration service now updates stored parameter values with new values during and after a failed update. As a result, when showing a stack, the parameter values will be the last ones supplied (as expected) even after a failed update.
Story Points: ---
Clone Of:
: 1263091 (view as bug list)
Environment:
Last Closed: 2015-10-08 08:20:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 215618 None None None Never

  None (edit)
Description Zane Bitter 2015-09-01 11:42:57 EDT
If a stack update fails, a subsequent stack-show will show the old parameter values rather than the ones we attempted to update with. It may even error out due to missing user parameters.

There is already a fix (under https://bugs.launchpad.net/heat/+bug/1477812) upstream in Liberty, and which has been proposed for backporting to Kilo.
Comment 9 Amit Ugol 2015-09-22 01:48:58 EDT
both required, required+default values and unused parameters are being updated to show the most recent update attempt.
Comment 11 errata-xmlrpc 2015-10-08 08:20:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1865

Note You need to log in before you can comment on or make changes to this bug.