Bug 125907 - Major new version available, readline not enabled, info file not installed, build dependencies missing
Major new version available, readline not enabled, info file not installed, b...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnuplot (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 129370 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-13 14:28 EDT by Jonathan Underwood
Modified: 2015-03-04 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 09:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RPM specification for building gnuplot 4.0 with GD and [x]emacs (2.05 KB, text/plain)
2004-06-17 13:57 EDT, Glen Turner
no flags Details

  None (edit)
Description Jonathan Underwood 2004-06-13 14:28:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
(1) A major new version has been released, version 4.0.0
(2) Previously the info file from the distribution was not included in
the rpm
(3) gnu readline library should be used to allow for a command line
history file
(4) the build pre-requisites did not previously include xorg-xll-devel

Below is an updated spec file:
Summary: A program for plotting mathematical expressions and data.
Name: gnuplot
Version: 4.0.0
Release: 0
License: Redistributable, with restrictions
Group: Applications/Engineering
Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-4.0.0.tar.gz
BuildPrereq: libpng-devel, tetex-latex, zlib-devel, readline-devel,
xorg-x11-dev
el
Requires: libpng readline
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
URL: http://www.gnuplot.info/

%description
Gnuplot is a command-line driven, interactive function plotting
program especially suited for scientific data representation.  Gnuplot
can be used to plot functions and data points in both two and three
dimensions and in many different formats.

Install gnuplot if you need a graphics package for scientific data
representation.

%prep
%setup -q

%build
%configure \
 --with-readline=gnu \
 --enable-history-file \
 --without-linux-vga \
 --without-gd \
 --with-png

make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"

cd docs
make html
PATH=$RPM_BUILD_DIR/gnuplot-%{version}:$PATH make

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

# remove unpackaged files from the buildroot
# rm -rf $RPM_BUILD_ROOT%{_infodir}

%post 
if [ "$1" = "1" ] ; then  # first install
 if [ -x /sbin/install-info ]; then
   /sbin/install-info /usr/share/info/gnuplot.info.gz /usr/share/info/dir
 fi
fi

%preun
if [ "$1" = "0" ] ; then # last uninstall
 if [ -x /sbin/install-info ]; then
   /sbin/install-info --delete /usr/share/info/gnuplot.info.gz
/usr/share/info/d
ir
 fi
fi

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc docs/gnuplot.html docs/psdoc tutorial/tutorial.dvi demo
%{_libexecdir}/gnuplot/4.0/gnuplot_x11%{_bindir}/gnuplot
%{_mandir}/man1/gnuplot.1.gz
%{_datadir}/gnuplot/4.0/gnuplot.gih
%{_infodir}/gnuplot.info.gz
%{_datadir}/emacs/site-lisp/gnuplot-gui.el
%{_datadir}/emacs/site-lisp/gnuplot-gui.elc
%{_datadir}/emacs/site-lisp/gnuplot.el
%{_datadir}/emacs/site-lisp/gnuplot.elc
%{_datadir}/emacs/site-lisp/info-look.20.2.el
%{_datadir}/emacs/site-lisp/info-look.20.3.el





Version-Release number of selected component (if applicable):
gnuplot-3.7.3-5

How reproducible:
Always

Steps to Reproduce:
1. Use current rpm
2.
3.
    

Additional info:
Comment 1 Glen Turner 2004-06-17 13:57:19 EDT
Created attachment 101220 [details]
RPM specification for building gnuplot 4.0 with GD and [x]emacs
Comment 2 Glen Turner 2004-06-17 14:03:23 EDT
The inline .spec file at the top of this bug report has some line wrap
issues, I've uploaded a correctly-wrapped file.

4.0 allows libpng or GD to be used to generate .png output. I've
selected the use of GD as the results seem significantly better.

I got some build failures for unpackaged files. This was because of
the presence of XEmacs on my system (presumably Emacs would have
caused the same failures).  These were solved by deleting excess info
dir files and the like.

Hope this is useful, Glen.
Comment 3 Phil Anderson 2004-06-25 21:35:47 EDT
I just used your spec file to build GnuPlot 4 on my system.  It failed
with:
error: File not found:
/var/tmp/gnuplot-4.0.0-0-root/usr/share/emacs/site-lisp/info-look.elc
Comment 4 Marc Castejon 2004-07-08 14:54:02 EDT
Hi, 
 
I tried that spec file and it didn't build for me (redhat 9.0), here is the spec file that 
did the job: 
---------8<----------8<-------------8<---------------8<-------------8<--------------- 
Summary: A program for plotting mathematical expressions and data. 
Name: gnuplot 
Version: 4.0.0 
Release: 0 
License: Redistributable, with restrictions 
Group: Applications/Engineering 
Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-4.0.0.tar.gz 
BuildPrereq: libpng-devel, tetex-latex, zlib-devel, readline-devel, xorg-x11-devel 
Requires: libpng readline 
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root 
URL: http://www.gnuplot.info/ 
 
%description 
Gnuplot is a command-line driven, interactive function plotting 
program especially suited for scientific data representation.  Gnuplot 
can be used to plot functions and data points in both two and three 
dimensions and in many different formats. 
 
Install gnuplot if you need a graphics package for scientific data 
representation. 
 
%prep 
%setup -q 
 
%build 
%configure \ 
 --with-readline=gnu \ 
 --enable-history-file \ 
 --without-linux-vga \ 
 --without-gd \ 
 --with-png 
 
make RPM_OPT_FLAGS="$RPM_OPT_FLAGS" 
 
cd docs 
make html 
PATH=$RPM_BUILD_DIR/gnuplot-%{version}:$PATH make 
 
 
%install 
rm -rf $RPM_BUILD_ROOT 
make install DESTDIR=$RPM_BUILD_ROOT 
 
#remove unpackaged files from the buildroot 
rm -f $RPM_BUILD_ROOT/usr/share/info/dir 
 
%post  
if [ "$1" = "1" ] ; then  # first install 
 if [ -x /sbin/install-info ]; then 
   /sbin/install-info /usr/share/info/gnuplot.info.gz /usr/share/info/dir 
 fi 
fi 
 
%preun 
if [ "$1" = "0" ] ; then # last uninstall 
 if [ -x /sbin/install-info ]; then 
   /sbin/install-info --delete /usr/share/info/gnuplot.info.gz /usr/share/info/dir 
 fi 
fi 
 
%clean 
rm -rf $RPM_BUILD_ROOT 
 
%files 
%defattr(-,root,root) 
%doc docs/gnuplot.html docs/psdoc tutorial/tutorial.dvi demo 
%{_libexecdir}/gnuplot/4.0/gnuplot_x11 
%{_bindir}/gnuplot 
%{_mandir}/man1/gnuplot.1.gz 
%{_datadir}/gnuplot/4.0/gnuplot.gih 
%{_infodir}/gnuplot.info.gz 
%{_datadir}/emacs/site-lisp/gnuplot-gui.el 
%{_datadir}/emacs/site-lisp/gnuplot-gui.elc 
%{_datadir}/emacs/site-lisp/gnuplot.el 
%{_datadir}/emacs/site-lisp/gnuplot.elc 
%{_datadir}/emacs/site-lisp/info-look.20.2.el 
%{_datadir}/emacs/site-lisp/info-look.20.3.el 
---------8<----------8<-------------8<---------------8<-------------8<--------------- 
 
Marc Castejon 
marc.castejon@laposte.net 
Comment 5 Matt Thompson 2004-07-28 13:41:19 EDT
As a big fan of gnuplot, and tired of waiting for the ner version to
appear in Rawhide, I decided to try this out.  No luck, and since I'm
not an RPM guru or a C guru (why are more programs built in Fortran
95! ;), I report here.

I'm reporting a failure to build with pdflib-lite-6.0.0 on my FC2 box
with the Comment #1 attachment.  Right after the link (I'm not
including here, long command) I get:

term.o(.text+0x2160e): In function `PDF_init':
../term/pdf.trm:346: undefined reference to `PDF_open_fp'

And, indeed, it would be undefined as pdflib-lite-6.0.0 (and, I guess,
pdflib-6.0.0) does not contain that function anymore.  A search
through the Interweb turns up:

http://www.devarchives.com/ml-display/93129/freebsd/Porting-software-to-FreeBSD-freebsd-portsfreebsdorg/Re-PDFlib-upgrade-in-FreeBSD-ports-tee

wherein it is said to replace PDF_open_fp with PDF_open_file.  This
would be line 346 in term/pdf.trm.

Effecting this change, though, doesn't quite work.  In building term.o
we get:

In file included from term.h:351,
                 from term.c:1005:
../term/pdf.trm: In function `PDF_init':
../term/pdf.trm:346: warning: passing arg 2 of `PDF_open_file' from
incompatible pointer type

I don't know enough about gcc, pdflib, &c., to tell if this is a fatal
warning, or just annoying.  Also, I get:

RPM build errors:
    File not found:
/var/tmp/gnuplot-4.0.0-0-root/usr/share/emacs/site-lisp/info-look.elc

and I'm too dumb I guess to figure out how Mr. Castejon fixed this
(any help?).
Comment 6 Matt Thompson 2004-08-04 09:51:04 EDT
OK, I think I figured part of it out.  In the attachment .spec file,
there is an additional line that isn't in the text pasted in the first
entry.  Namely:

%{_datadir}/emacs/site-lisp/info-look.elc

I'm not sure why that is, but there you go.  Since I don't use
[x]emacs at all, I'm guessing I won't mind it gone.  And the build
succeeds without it.

Now I need a C programmer to tell me about the warning in term.
Comment 7 Jonathan Underwood 2004-08-04 10:07:40 EDT
Yes, I found that, although I have xemacs installed, I didn't need
that very same line in the spec file. Following comment 2 though, I
did build with gd enabled subsequently. I've not been able to
reproduce the pdflib problems at all. Are you adding in something to
configure that isn't indicated in the spec files above?
Comment 8 Matt Thompson 2004-08-04 11:48:59 EDT
The pdflib issue is fixed.  Following a Google thread through to the
gnuplot CVS, it seems they too have encountered this.  To wit:

    /*open new PDF file */
    /* HBB FIXME 20040708: PDF_open_file is deprecated, will have to
     * be re-done again soon. */
    if (PDF_open_file(myPDF, outstr) == -1)
	int_error(NO_CARET, "Error:cannot open PDF file .\n");

Using this if-statement allows successful build with
pdflib-lite-6.0.0, but presages that more changes are coming.  If
gnuplot-4.0.0 and pdflib-lite-6.0.0 ever become official packages, a
backported patch will be needed.  Else, a wait for gnuplot-4.1 should
make this moot.
Comment 9 Bill Nottingham 2004-08-06 22:42:28 EDT
*** Bug 129370 has been marked as a duplicate of this bug. ***
Comment 10 Phil Knirsch 2004-09-27 09:44:32 EDT
New version is in Rawhide (should already be in FC3 Test2)

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.