Bug 1259220 - [TUI] There is error report when click "Set Console Path"
[TUI] There is error report when click "Set Console Path"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Ryan Barry
Huijuan Zhao
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 04:45 EDT by Huijuan Zhao
Modified: 2016-03-09 09:36 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.10.20150928gite7ee3f1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:36:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport and /var/log (6.39 MB, application/x-gzip)
2015-09-02 04:45 EDT, Huijuan Zhao
no flags Details
error report of set console path (10.95 KB, image/png)
2015-09-02 04:59 EDT, Huijuan Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46043 master MERGED Move initramfs regeneration until after grub is installed Never
oVirt gerrit 46105 ovirt-3.6 MERGED Move initramfs regeneration until after grub is installed Never

  None (edit)
Description Huijuan Zhao 2015-09-02 04:45:59 EDT
Created attachment 1069301 [details]
sosreport and /var/log

Description of problem:
There is error report when click "Set Console Path" in "Status" page


Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20150831.0
ovirt-node-3.3.0-0.2.20150722git7eba125.el7ev.noarch

How reproducible:
100%
QA Whiteboard: node
Regression bug

Steps to Reproduce:
1. Clean install rhev-hypervisor-7-7.2-20150831.0
2. Enter "Status" page
3. Click "Set Console Path"

Actual results:
After step3, there is error report:
--------------------------------------------
An error appeared in the UI: RuntimeError('Grub config file does not exist: <ovirt.node.utils.fs.File object at 0x46febd0>',)
Press ENTER to logout ...
or enter 's' to drop to shell
--------------------------------------------


Expected results:
After step3, there should be no error report, and can enter "Set Console Path" success.

Additional info:
Comment 1 Huijuan Zhao 2015-09-02 04:59:41 EDT
Created attachment 1069302 [details]
error report of set console path
Comment 2 Ying Cui 2015-09-02 04:59:53 EDT
this issue is regression, and higher this bug severity due to we have costumer requested this feature before, see bug 966302
Comment 5 Huijuan Zhao 2015-10-25 22:49:49 EDT
Test version:
rhev-hypervisor7-7.2-20151025.iso
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch

Test Steps:
1. Clean install rhev-hypervisor7-7.2-20151025.iso
2. Enter "Status" page
3. Click "Set Console Path"

Test results:
After step3, can enter "Set Console Path" and config successful.

So this bug has been fixed, changed the status into "VERIFIED".
Comment 7 errata-xmlrpc 2016-03-09 09:36:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.