Bug 966302 - PRD35 - [RFE]setup serial console for RHEVH
PRD35 - [RFE]setup serial console for RHEVH
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
2.1.0
All Linux
urgent Severity medium
: ---
: 3.5.0
Assigned To: Ryan Barry
Virtualization Bugs
node
: FutureFeature
: 1040407 (view as bug list)
Depends On: 984939 rebase-ovirt-node-3.1
Blocks: 1123936 rhev3.5beta 1156165
  Show dependency treegraph
 
Reported: 2013-05-22 21:57 EDT by Pratik Pravin Bandarkar
Modified: 2016-02-10 15:02 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This feature enables the default console device to be set from within the Red Hat Enterprise Virtualization Hypervisor setup TUI.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-11 15:45:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17982 None None None Never
oVirt gerrit 34274 None None None Never

  None (edit)
Description Pratik Pravin Bandarkar 2013-05-22 21:57:08 EDT
1. Proposed title of this feature request
setup serial console for RHEVH

2. Who is the customer behind the request?
Account: name (acct #) 5262884
TAM customer: No
SRM customer: No
Strategic:    no

3. What is the nature and description of the request?
Customer wants to setup serial console for RHEV-H. We can append serial console details to kernel line when RHEV-H is booting.
---
console=ttyS1,57600n8  <== for example.
---

But, customer wants to make persistant entry in grub.conf file. By-default, grub.conf file is in read-only mode. and to modify grub.conf we will need to remount it in rw mode. But, login to RHEVH shell with root access and making any modification is not supported by Red Hat. So, customer wants supported way to configure the same.

We do have workaround:
<snip>
To modify the grub.conf, remount /dev/.initramfs/live in read-write mode as, it is symlink to /boot/grub/
---
# mount -o remount,rw /dev/.initramfs/live
---
Then modify grub.conf file and append serial console parameters to kernel line.
</snip>


4. Why does the customer need this? (List the business requirements here)
We use Dell's serial over lan capability to remotely manage our systems.

5. How would the customer like to achieve this? (List the functional requirements here)
Ability to append console=ttyS0,115200 to the kernel line in /etc/grub.conf in a supported fashion (through the Admin menu I'd guess).

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
No.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
Sooner the better.

9. Is the sales team involved in this request and do they have any additional input?
No.

10. List any affected packages or components.

11. Would the customer be able to assist in testing this functionality if implemented?
 Yes.
Comment 12 Fabian Deutsch 2014-06-11 09:47:15 EDT
*** Bug 1040407 has been marked as a duplicate of this bug. ***
Comment 13 Itamar Heim 2014-06-22 08:59:14 EDT
Fabian - the linked patch has been merged upstream - isn't this in 3.5 via a rebase?
Comment 14 Fabian Deutsch 2014-06-25 07:04:58 EDT
Hey Itamar,

yep it is going to get in through the rebase.
Comment 16 Fabian Deutsch 2014-07-24 12:02:21 EDT
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.
Comment 18 Ying Cui 2014-10-15 04:24:30 EDT
Move this bug to Assigned, partial fix, but partial non-fix.

non-fix is in node, console parameter in cmdline accept console=ttyS0,115200n8, not console=/dev/ttyS0,115200n8

Test version:
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch
Red Hat Enterprise Virtualization Hypervisor release 7.0 (20141006.0.el7ev)

Test steps:
1. Installed rhevh successful.
2. login rhevh
3. 'Set Console Path' in TUI, this field _only_ accept "/dev/ttyS0,115200n8"
4. After saving, check grub.cfg, it has been added. console=/dev/ttyS0,115200n8
5. reboot rhevh
6. #minicom

Result: no output from serial console.

update console=/dev/ttyS0,115200n8 to console=ttyS0,115200n8, rhevh can be booted successful with serial console.
Comment 19 Ying Cui 2014-10-15 04:27:12 EDT
I update the priority to urgent because it is 3.5 RFE, and has customer ticket on it.
Comment 20 Ying Cui 2014-12-15 07:42:56 EST
Tested on build:
ovirt-node-3.1.0-0.34.20141210git0c9c493.el6.noarch
Red Hat Enterprise Virtualization Hypervisor release 6.6 (20141212.0.el6ev)
and
ovirt-node-3.1.0-0.34.20141210git0c9c493.el7.noarch
Red Hat Enterprise Virtualization Hypervisor release 7.0 (20141212.0.el7ev)

Test steps:
1. Installed rhevh successful.
2. login rhevh
3. 'Set Console Path' in TUI-Status, this field "/dev/ttyS0,115200n8" or /dev/ttyS1
4. After saving, check grub.cfg, it has been added. console=ttyS0,115200n8 or console=ttyS1
5. reboot rhevh 

Can console access successful.
Comment 22 errata-xmlrpc 2015-02-11 15:45:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html

Note You need to log in before you can comment on or make changes to this bug.