Bug 1259240 - pbs_mom init script tries to use uninstalled binary
Summary: pbs_mom init script tries to use uninstalled binary
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: torque
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1310600 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-02 09:26 UTC by Mattias Ellert
Modified: 2016-03-16 13:31 UTC (History)
5 users (show)

Fixed In Version: torque-4.2.10-8.fc23 torque-4.2.10-8.fc22 torque-4.2.10-8.el5 torque-4.2.10-8.el7 torque-4.2.10-8.el6 torque-4.2.10-9.el5 torque-4.2.10-9.el7 torque-4.2.10-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-23 22:30:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Mattias Ellert 2015-09-02 09:26:23 UTC
Description of problem:

# service pbs_mom restart
Shutting down TORQUE Mom: /etc/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory

Version-Release number of selected component (if applicable):

torque-mom-4.2.10-5.el6.x86_64

How reproducible:

Always

Steps to Reproduce:
1. service pbs_mom restart

Actual results:

/usr/sbin/momctl: No such file or directory

Expected results:

Restart of service without errors

Additional info:

The /usr/sbin/momctl binary is available in the torque-client and torque-server packages - is this binary needed on a server or client?

The /usr/sbin/momctl binary is not available in the torque-mom package - but it is definitely needed on a mom!

If it is really needed on both client, server and mom, it should be in the main torque package and not in three different packages (similar to trqauthd), if it is only needed on mom it should only be in the mom package and not in client or server.

Comment 1 Fedora Update System 2015-12-07 02:05:56 UTC
torque-4.2.10-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7fab0e17fe

Comment 2 Fedora Update System 2015-12-07 02:06:20 UTC
torque-4.2.10-8.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fed8081a94

Comment 3 Fedora Update System 2015-12-07 02:06:49 UTC
torque-4.2.10-8.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-291545b6fd

Comment 4 Fedora Update System 2015-12-07 02:18:06 UTC
torque-4.2.10-8.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-1855821fe8

Comment 5 Fedora Update System 2015-12-07 02:18:28 UTC
torque-4.2.10-8.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-22cbfeb20e

Comment 6 Fedora Update System 2015-12-07 23:22:15 UTC
torque-4.2.10-8.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update torque'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fed8081a94

Comment 7 Fedora Update System 2015-12-08 04:32:06 UTC
torque-4.2.10-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update torque'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7fab0e17fe

Comment 8 Fedora Update System 2015-12-08 07:19:54 UTC
torque-4.2.10-8.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update torque'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-1855821fe8

Comment 9 Fedora Update System 2015-12-08 07:21:38 UTC
torque-4.2.10-8.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update torque'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-291545b6fd

Comment 10 Fedora Update System 2015-12-08 07:47:53 UTC
torque-4.2.10-8.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update torque'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-22cbfeb20e

Comment 11 Fedora Update System 2015-12-14 10:21:48 UTC
torque-4.2.10-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-12-26 21:52:12 UTC
torque-4.2.10-8.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-02-21 08:09:41 UTC
torque-4.2.10-9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-80daa121a4

Comment 14 Fedora Update System 2016-02-21 08:10:08 UTC
torque-4.2.10-9.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-652d4f3054

Comment 15 Fedora Update System 2016-02-21 08:10:35 UTC
torque-4.2.10-9.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f2f3898eca

Comment 16 Fedora Update System 2016-02-22 03:48:32 UTC
torque-4.2.10-9.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f2f3898eca

Comment 17 Fedora Update System 2016-02-22 03:48:40 UTC
torque-4.2.10-9.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-652d4f3054

Comment 18 Fedora Update System 2016-02-22 04:51:05 UTC
torque-4.2.10-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-80daa121a4

Comment 19 David Brown 2016-02-22 16:26:52 UTC
*** Bug 1310600 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2016-02-23 22:30:43 UTC
torque-4.2.10-8.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2016-02-24 17:59:53 UTC
torque-4.2.10-8.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2016-02-24 18:54:45 UTC
torque-4.2.10-8.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Daniel Challen 2016-02-25 15:38:51 UTC
The updates works for me on RHEL6. Thank you, and sorry for making the dupe bug.

Comment 24 David Brown 2016-02-25 17:16:53 UTC
That's alright it was my fault for leaving an update sit for 3 months in testing instead of pushing it to stable...

Comment 25 Fedora Update System 2016-03-15 22:01:43 UTC
torque-4.2.10-9.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2016-03-15 22:47:52 UTC
torque-4.2.10-9.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2016-03-16 13:30:45 UTC
torque-4.2.10-9.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.