Bug 1310600 - /usr/sbin/momctl is packaged in torque-server, it should be in torque-mom
/usr/sbin/momctl is packaged in torque-server, it should be in torque-mom
Status: CLOSED DUPLICATE of bug 1259240
Product: Fedora EPEL
Classification: Fedora
Component: torque (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Brown
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 05:34 EST by Daniel Challen
Modified: 2016-02-22 11:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 11:26:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Challen 2016-02-22 05:34:48 EST
The torque-mom package requires the binary momctl. Its init script calls /usr/sbin/momctl to stop the daemon, however the binary is mistakenly included in the torque-server (and also torque-client) package, so on a system with only torque-mom installed (a common configuration) the initscript cannot work properly. Excerpt from a RHEL6 system.

[dan@node14 ~]$ rpm -qf /etc/rc.d/init.d/pbs_mom 
torque-mom-4.2.10-5.el6.x86_64
[dan@node14 ~]$ grep momctl /etc/rc.d/init.d/pbs_mom
      $SBIN_PATH/momctl -s
[dan@node14 ~]$ sudo /etc/rc.d/init.d/pbs_mom stop
Shutting down TORQUE Mom: /etc/rc.d/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/rc.d/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/rc.d/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
/etc/rc.d/init.d/pbs_mom: line 44: /usr/sbin/momctl: No such file or directory
^C[dan@node14 ~]$ yum provides /usr/sbin/momctl
Loaded plugins: product-id, security, subscription-manager
torque-server-4.2.10-5.el6.x86_64 : The main part of TORQUE
Repo        : epel
Matched from:
Filename    : /usr/sbin/momctl



torque-client-4.2.10-5.el6.x86_64 : Client part of TORQUE
Repo        : epel
Matched from:
Filename    : /usr/sbin/momctl


This is 100% reproducible
Comment 1 Thomas Moschny 2016-02-22 05:44:49 EST
Correcting wrong component.
Comment 2 David Brown 2016-02-22 11:26:52 EST
This is a duplicate of #1259240

And I thought I fixed it... I'll have to check if I hit the "This is stable" button in koji for el6...

*** This bug has been marked as a duplicate of bug 1259240 ***

Note You need to log in before you can comment on or make changes to this bug.