Bug 1259247 - [7.2-3.6] Failed to approve RHEV-H in RHEV-M 3.5
[7.2-3.6] Failed to approve RHEV-H in RHEV-M 3.5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Yaniv Bronhaim
Pavol Brilla
: AutomationBlocker, Regression, TestBlocker
: 1260470 (view as bug list)
Depends On:
Blocks: 1172511 1204470 1245143
  Show dependency treegraph
 
Reported: 2015-09-02 05:34 EDT by cshao
Modified: 2016-03-09 14:44 EST (History)
22 users (show)

See Also:
Fixed In Version: 3.6.0-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 14:44:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/*.* + engine.log + sosreport (7.34 MB, application/x-gzip)
2015-09-02 05:34 EDT, cshao
no flags Details
host-deploy (273.16 KB, text/plain)
2015-09-08 02:55 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45846 master MERGED configurator doesn't load pyc files under configurators folder Never
oVirt gerrit 46011 ovirt-3.6 MERGED configurator doesn't load pyc files under configurators folder Never

  None (edit)
Description cshao 2015-09-02 05:34:36 EDT
Created attachment 1069316 [details]
/var/log/*.* + engine.log + sosreport

Description of problem:
[7.2-3.6] Failed to register RHEV-H to RHEV-M 3.5

Message: Host dell-op790-01.qe.lab.eng.nay.redhat.com installation failed         Host not reachable.


Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20150831.0
ovirt-node-3.3.0-0.2.20150722git7eba125.el7ev.noarch
vdsm-4.17.3-1.el7ev.noarch
RHEV-M vt16.8
Red Hat Enterprise Virtualization Manager Version: 3.5.4-1.3.el6ev

How reproducible:
100%

Steps to Reproduce:
1. TUI install rhev-hypervisor-7-7.2-20150831.0
2. Register RHEV-H to RHEV-M (compatibility is 3.5).
3. 

Actual results:
Failed to register RHEV-H to RHEV-M.

Expected results:
No such issue on rhev-hypervisor-7-7.1-20150827.1 build, so this is a regression bug from 7.1 to 7.2.
Register RHEV-H to RHEV-M can successful.

Additional info:
Comment 1 cshao 2015-09-02 05:36:05 EDT
Add keyword:regression due to no such issue on rhev-hypervisor-7-7.1-20150827.1 build, so this is a regression bug from 7.1 to 7.2.
Comment 3 Douglas Schilling Landgraf 2015-09-02 09:07:18 EDT
As talked with Ying over irc, the issue happens during the approval not during the registration.

From vdsm logs, might be related to polkit:

MainThread::ERROR::2015-09-02 04:44:53,319::vdsm::159::vds::(run) Exception raised
Traceback (most recent call last):
  File "/usr/share/vdsm/vdsm", line 157, in run
    serve_clients(log)
  File "/usr/share/vdsm/vdsm", line 94, in serve_clients
    cif = clientIF.getInstance(irs, log)
  File "/usr/share/vdsm/clientIF.py", line 192, in getInstance
  File "/usr/share/vdsm/clientIF.py", line 110, in __init__
  File "/usr/share/vdsm/virt/secret.py", line 91, in clear
  File "/usr/lib/python2.7/site-packages/vdsm/libvirtconnection.py", line 163, in get
  File "/usr/lib/python2.7/site-packages/vdsm/libvirtconnection.py", line 100, in open_connection
  File "/usr/lib/python2.7/site-packages/vdsm/utils.py", line 949, in retry
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 105, in openAuth
libvirtError: authentication failed: no agent is available to authenticate
Comment 5 Dan Kenigsberg 2015-09-07 07:42:48 EDT
Looking at /etc/libvirt/libvirtd.conf we see that `vdsm-tool configured` was not called (it has not "vdsm" section).

However, /var/log/messages has a successful

 Sep  2 04:22:10 dell-op790-01 vdsmd_init_common.sh: vdsm: Running check_is_configured

Can you attack ovirt-host-deploy logs from the Engine?
Can you provide access to such a host?

(I don't know if this is a node or infra bug, but it's certainly not network.)
Comment 6 Oved Ourfali 2015-09-07 08:08:08 EDT
Are you working with 3.5 engine? or 3.6 engine with 3.5 compatibility level?
Comment 8 cshao 2015-09-08 02:55:47 EDT
Created attachment 1071211 [details]
host-deploy
Comment 12 Douglas Schilling Landgraf 2015-09-23 13:19:07 EDT
Hi Yaniv,

Could you please set the 'Fixed in Version' field? I would like to make sure we include the right vdsm in the next node build.

Thanks!
Comment 13 Douglas Schilling Landgraf 2015-09-23 13:30:19 EDT
*** Bug 1260470 has been marked as a duplicate of this bug. ***
Comment 14 Pavol Brilla 2015-12-15 05:09:52 EST
verified:

RHEVM: 3.5.6.2-0.1.el6ev


Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151210.1.el7ev)
vdsm-4.17.13-1.el7ev.noarch
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch
Comment 16 errata-xmlrpc 2016-03-09 14:44:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html

Note You need to log in before you can comment on or make changes to this bug.