Bug 1204470 - Impossible to turn RHEVH host to global maintenance via CLI, in HE environment.
Summary: Impossible to turn RHEVH host to global maintenance via CLI, in HE environment.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.5.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Douglas Schilling Landgraf
QA Contact: wanghui
URL:
Whiteboard:
Depends On: 1259247 1260470 1278548 1280268
Blocks: 1059435 1193058 1198639 1235567 1250199
TreeView+ depends on / blocked
 
Reported: 2015-03-22 12:26 UTC by Nikolai Sednev
Modified: 2016-07-04 00:39 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev rhev-hypervisor7-7.2-20150831.0.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1235567 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:18:52 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 39253 master MERGED rwtab:/var/lib/ovirt-hosted-engine-ha should be rw Never
oVirt gerrit 39254 ovirt-3.5 MERGED rwtab:/var/lib/ovirt-hosted-engine-ha should be rw Never

Description Nikolai Sednev 2015-03-22 12:26:42 UTC
Description of problem:
Impossible to turn RHEVH host to global maintenance via CLI, in HE environment, which blocks the RHEVM upgrade for engine that's running on top of RHEVH host.  

[root@alma03 ~]# hosted-engine --set-maintenance --mode=global
Traceback (most recent call last):
  File "/usr/lib64/python2.6/runpy.py", line 122, in _run_module_as_main
  File "/usr/lib64/python2.6/runpy.py", line 34, in _run_code
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_setup/set_maintenance.py", line 72, in <module>
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_setup/set_maintenance.py", line 56, in set_mode
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/client/client.py", line 255, in set_maintenance_mode
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/env/config.py", line 101, in set
IOError: [Errno 30] Read-only file system: '/var/lib/ovirt-hosted-engine-ha/ha.conf'

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Deploy HE on RHEVH and try to put the host in to the global maintenance mode.
2.
3.

Actual results:
IOError: [Errno 30] Read-only file system: '/var/lib/ovirt-hosted-engine-ha/ha.conf'

Expected results:
Global and local maintenance have to be available for RHEVH.

Additional info:
You might consider moving required config files to TMP for maintenance to be possible.

Comment 1 Fabian Deutsch 2015-03-26 13:23:48 UTC
This looks like a persistence bug on node, taking it over.

Comment 2 Ying Cui 2015-03-31 12:06:17 UTC
This bug need zstream clone. Thanks.

Comment 4 Nikolai Sednev 2015-09-07 14:32:24 UTC
Hi Fabian,
Please provide relevant RHEVH7.2-HE image link, so this bug could be verified.
Currently we don't have required RHEVH-HE image, which also 3.6 compatible.

Comment 6 wanghui 2015-11-12 03:33:35 UTC
Test version:
rhev-hypervisor7-7.2-20151104.0.iso
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch

Test steps:
1. Configure hosted engine succeed
2. Click <Set Hosted Engine maintenance> to setup global mode

Test result:
1. The "global" level can be setup succeed.

So this issue is fixed in ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch.

Comment 8 errata-xmlrpc 2016-03-09 14:18:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.