Bug 1259287 - Please set REDHAT_BUGZILLA_PRODUCT_VERSION to "rawhide"
Please set REDHAT_BUGZILLA_PRODUCT_VERSION to "rawhide"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
: 1267841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 07:21 EDT by Jakub Filak
Modified: 2016-11-30 19:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-29 11:34:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Filak 2015-09-02 07:21:10 EDT
Description of problem:
When I was testing ABRT's capability to open a new bug in http://partner-bugzilla.redhat.com/ (version 4.4.9039-3), I found out the server no longer accepts the 'Rawhide' string in Version. The string is currently used as a value of "REDHAT_BUGZILLA_PRODUCT_VERSION=" option in /etc/os-release.

The correct value of the option is 'rawhide'. That string is accepted by the production system too (bug #1185157 comment #10)


Version-Release number of selected component (if applicable):
fedora-release-24-0.1.noarch
Comment 1 Jakub Filak 2015-09-24 12:21:54 EDT
Updating Priority because Rawhide users cannot use ABRT to report crashes to Red Hat Bugzilla.
Comment 2 Kevin Fenzi 2015-09-24 20:39:21 EDT
Hum... I changed /etc/os-release here to have: 

REDHAT_BUGZILLA_PRODUCT_VERSION=rawhide

and it still failed. Does it cache that value at startup or something?
Comment 3 Jakub Filak 2015-09-25 03:32:36 EDT
(In reply to Kevin Fenzi from comment #2)
> Hum... I changed /etc/os-release here to have: 
> 
> REDHAT_BUGZILLA_PRODUCT_VERSION=rawhide
> 
> and it still failed. Does it cache that value at startup or something?

Yes, it does. If you want to test the change, you need to change directory to /var/spool/abrt/$problem_id and edit the file "os_info". Or you can generate a new problem (dnf install will-crash && will_segfault).
Comment 4 Kevin Fenzi 2015-09-25 20:00:28 EDT
I did edit the os_info and it has "rawhide" in it, but reporting still gives me a:

fatal: RPC failed at server.  There is no version named 'Rawhide' in the 'Fedora' product.
('report_Bugzilla' exited with 1)

Would there be any other place that needs changed/restarted?
Comment 5 Kevin Fenzi 2015-09-28 11:24:16 EDT
ok, checking again, I might have changed the wrong one (not the one I was reporting).

I was able to file a report with it changed. ;)
Comment 6 Dennis Gilmore 2015-09-29 11:34:57 EDT
shoudl be fixed as of rawhide today
Comment 7 Jakub Filak 2015-10-01 04:33:58 EDT
*** Bug 1267841 has been marked as a duplicate of this bug. ***
Comment 8 Petr Lautrbach 2015-10-01 04:44:47 EDT
Works for me. Thanks!

Note You need to log in before you can comment on or make changes to this bug.