Bug 1259288 - [RHEVM-RHGS] RHGS bootstrapping invokes with older RHGS tuned profile name
[RHEVM-RHGS] RHGS bootstrapping invokes with older RHGS tuned profile name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
x86_64 Linux
medium Severity high
: ovirt-4.0.0-rc
: ---
Assigned To: Sahina Bose
SATHEESARAN
:
Depends On:
Blocks: 1249979
  Show dependency treegraph
 
Reported: 2015-09-02 07:21 EDT by SATHEESARAN
Modified: 2016-08-23 16:28 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, new tuned profiles that were introduced in Red Hat Enterprise Linux 7 for Red Hat Gluster Storage was not available in the Red Hat Gluster Storage Console. As a consequence, users were unable to set the tuned profile from console. With this update, users can select cluster specific profiles using console.
Story Points: ---
Clone Of:
Environment:
RHGS 3.1
Last Closed: 2016-08-23 16:28:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51159 ovirt-engine-3.6 MERGED engine: Support cluster level gluster tuned profiles 2016-01-14 04:18 EST
oVirt gerrit 51160 ovirt-engine-3.6 MERGED gluster: fix tuned profile entries 2016-01-14 04:20 EST
oVirt gerrit 51186 ovirt-engine-3.6 MERGED webadmin: fixing cluster and tuned profile selection 2016-01-14 04:42 EST

  None (edit)
Description SATHEESARAN 2015-09-02 07:21:57 EDT
Description of problem:
-----------------------
With RHGS 3.1 , tuned-profiles for RHGS are renamed as 'rhgs-sequential-io'

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1
RHEV 3.5.3

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Add RHGS node in gluster-service enabled cluster

Actual results:
---------------
Errors seen while setting tuned profile named 'rhs-virtualization'

Expected results:
-----------------
New rhgs tuned profile 'rhgs-sequential-io' should be set instead of 'rhs-virtualization'

Additional Info:
-----------------
Error messages as seen ovirt host deploy logs

<snip>
2015-09-02 03:46:01 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.executeRaw:824 execute: ('/sbin/tuned-adm', 'profile', 'rhs-virtualization'), executable='None', cwd='None', env=None
2015-09-02 03:46:51 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.executeRaw:874 execute-result: ('/sbin/tuned-adm', 'profile', 'rhs-virtualization'), rc=1
2015-09-02 03:46:51 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.execute:932 execute-output: ('/sbin/tuned-adm', 'profile', 'rhs-virtualization') stdout:


2015-09-02 03:46:51 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.execute:937 execute-output: ('/sbin/tuned-adm', 'profile', 'rhs-virtualization') stderr:
2015-09-02 03:46:26,610 ERROR    dbus.proxies: Introspect error on :1.2:/Tuned: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
ERROR:dbus.proxies:Introspect error on :1.2:/Tuned: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
DBus call to Tuned daemon failed
Requested profile 'rhs-virtualization' doesn't exist.

2015-09-02 03:46:51 WARNING otopi.plugins.ovirt_host_deploy.tune.tuned tuned._misc:91 Cannot set tuned profile
2015-09-02 03:46:51 DEBUG otopi.context context._executeMethod:138 Stage misc METHOD otopi.plugins.ovirt_host_deploy.vdsm.bridge.Plugin._misc
2015-09-02 03:46:51 DEBUG otopi.context context._executeMethod:144 condition False
</snip>
Comment 2 SATHEESARAN 2015-09-02 07:37:38 EDT
Refer this bug for RHSC - https://bugzilla.redhat.com/show_bug.cgi?id=1242902
Comment 4 Sahina Bose 2015-12-10 05:36:00 EST
Need to backport tuned profile related patches to 3.6.
Comment 5 SATHEESARAN 2016-04-18 04:12:28 EDT
Added RHGS 3.1.2 node to 3.5 cluster.

While creating the cluster chosen the tuned-profile as "rhs-virtualization",
but still I see the error "Unable to set tuned profile" in logs

As I get the information from Sahina, it looks like this bug can't be verified for RHEV 3.6.5 as RHGS 3.1.2 or RHGS 3.1.3 couldn't be managed by RHEV 3.6 in 3.6 cluster.

@Sahina, what should be the ideal state this bug should be in ?
Comment 6 Sahina Bose 2016-04-18 07:48:05 EDT
With RHGS 3.1.x - the nodes can only be added to a 3.5 cluster and the new tuned profiles are only supported from 3.6 cluster.
Comment 7 SATHEESARAN 2016-05-16 01:58:44 EDT
Bronce,

This bug couldn't be verified for RHEV 3.6.6 too as because of the reason mentioned in comment6

Probably this bug needs to be moved to the RHEV release, when RHGS ships the compatible vdsm ( 4.17.* ), so that RHGS node can be added to RHEV 3.6 cluster
Comment 8 Bronce McClain 2016-05-18 10:20:53 EDT
(In reply to SATHEESARAN from comment #7)
> Bronce,
> 
> This bug couldn't be verified for RHEV 3.6.6 too as because of the reason
> mentioned in comment6
> 
> Probably this bug needs to be moved to the RHEV release, when RHGS ships the
> compatible vdsm ( 4.17.* ), so that RHGS node can be added to RHEV 3.6
> cluster

Do we know when that version of vdsm will be included in RHGS? I'll re-target this to RHEV 3.6.7 for now as that will be the next release on 22-June.
Comment 9 SATHEESARAN 2016-05-18 12:40:44 EDT
(In reply to Bronce McClain from comment #8)
> Do we know when that version of vdsm will be included in RHGS? I'll
> re-target this to RHEV 3.6.7 for now as that will be the next release on
> 22-June.

Bronce I don't have that information

Sahina, 

Do we have the information required by Bronce in comment8 ?
Comment 10 Sahina Bose 2016-05-23 08:36:19 EDT
RHGS 3.1.x has 4.16.* versions - which cannot be added to 3.6 clusters. This bug will need to wait for an RHGS 3.2 
I will retarget to 4.0
Comment 11 SATHEESARAN 2016-08-17 06:32:44 EDT
Tested with RHGS 3.1.3 ( with vdsm 4.17.33-1 ) and RHV 4.0.2-6 by adding this node to the 3.6 cluster. The gluster cluster is created with tuned-profile set to rhgs-random and the newly added nodes has this profile set
Comment 13 errata-xmlrpc 2016-08-23 16:28:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.