Bug 1249979 - [New] - Introduce the profiles rhgs-sequential-io and rhgs-random-io in rhsc while creating a cluster.
[New] - Introduce the profiles rhgs-sequential-io and rhgs-random-io in rhsc ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
3.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 3.1.2
Assigned To: Sahina Bose
RHS-C QE
: ZStream
: 1242902 (view as bug list)
Depends On: 1251360 1259288
Blocks: 1216951 1260783
  Show dependency treegraph
 
Reported: 2015-08-04 05:53 EDT by RamaKasturi
Modified: 2016-09-09 01:22 EDT (History)
10 users (show)

See Also:
Fixed In Version: rhsc-3.1.2-0.68
Doc Type: Bug Fix
Doc Text:
Previously, new tuned profiles that were introduced in Red Hat Enterprise Linux 7 for Red Hat Gluster Storage was not available in the Red Hat Gluster Storage Console. As a consequence, users were unable to set the tuned profile from console. With this update, users can select cluster specific profiles using console.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:10:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (163.96 KB, image/png)
2015-11-24 02:50 EST, Triveni Rao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47814 master MERGED engine: Support cluster level gluster tuned profiles Never
oVirt gerrit 48169 ovirt-engine-3.5-gluster MERGED engine: Support cluster level gluster tuned profiles Never
oVirt gerrit 49459 ovirt-engine-3.5-gluster MERGED gluster: fix tuned profile entries Never
oVirt gerrit 51159 ovirt-engine-3.6 MERGED engine: Support cluster level gluster tuned profiles 2016-01-14 04:18 EST

  None (edit)
Description RamaKasturi 2015-08-04 05:53:09 EDT
Description of problem:
As of now the profiles which are listed in rhsc are not compatible with RHEL7 node and when user adds a RHEL7 node to RHSC it does not set any profile on these nodes since the profiles which are compatible with RHEL7 based RHGS node which are rhgs-sequential-io and rhgs-random-io are not present in rhsc while user creates a cluster.

Version-Release number of selected component (if applicable):
rhsc-3.1.0-0.62.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
There are no profiles called rhgs-random-io and rhgs-sequential-io present in rhsc which user can select while creating a cluster.

Expected results:
Introduce two new profiles called rhgs-random-io and rhgs-sequential-io in RHSC while user creates a cluster

Additional info:
Comment 2 RamaKasturi 2015-08-04 06:37:26 EDT
For more info, please refer to the bug https://bugzilla.redhat.com/show_bug.cgi?id=1248420
Comment 5 SATHEESARAN 2015-09-02 07:38:25 EDT
Here is the related bug for RHEVM
https://bugzilla.redhat.com/show_bug.cgi?id=1259288
Comment 6 Sahina Bose 2015-09-03 02:23:13 EDT
Tuned profiles need to be cluster level specific and should have a brief description to show in an info bubble in the UI
Comment 7 Sahina Bose 2015-09-03 02:42:33 EDT
*** Bug 1242902 has been marked as a duplicate of this bug. ***
Comment 9 Triveni Rao 2015-11-24 02:50:00 EST
On the RHSC UI, while creating Cluster i see that all the 3 profiles are listed.
It supposed to list only the new profiles rhgs-random-io and rhgs-sequential-io applicable for both RHEL6.7 and RHEL7.2 RHGS nodes.

Attached is the screen shot, showing rhs-high-throughput profile while cluster creation.
Comment 10 Triveni Rao 2015-11-24 02:50 EST
Created attachment 1098023 [details]
screenshot
Comment 11 Sahina Bose 2015-11-30 11:30:30 EST
Added additional checks before setting the selected item in dropdown - which fixes the issue with additional profile shown for 3.5 cluster.
Comment 12 Triveni Rao 2015-12-11 05:13:06 EST
This is verified with above mentioned build rhsc-3.1.2-0.67 → rhsc-3.1.2-0.68.

Steps followed:
1. create cluster with 3.5 version choosing the profile sequential-io
2. create one more cluster with 3.5 and the profile set to random-io.
3. add hosts to the clusters
4. check the back end to confirm (tuned-adm list) tuned profiles are set as per the cluster profiles.

Output:
========

For RHEL6.7 Host:
++++++++++++++++++

[root@dhcp37-136 yum.repos.d]# tuned-adm list
Available profiles:
- desktop-powersave
- rhgs-random-io
- virtual-host
- latency-performance
- rhgs-sequential-io
- laptop-battery-powersave
- rhs-high-throughput
- virtual-guest
- spindown-disk
- enterprise-storage
- server-powersave
- rhs-virtualization
- laptop-ac-powersave
- throughput-performance
- default
Current active profile: default

[root@dhcp37-136 yum.repos.d]# 
[root@dhcp37-136 yum.repos.d]# cat /etc/redhat-storage-release 
Red Hat Gluster Storage Server 3.1 Update 2
[root@dhcp37-136 yum.repos.d]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.7 (Santiago)
[root@dhcp37-136 yum.repos.d]# 

[root@dhcp37-136 yum.repos.d]# rpm -qa | grep gluster
vdsm-gluster-4.16.30-1.2.el6rhs.noarch
glusterfs-client-xlators-3.7.5-11.el6rhs.x86_64
glusterfs-server-3.7.5-11.el6rhs.x86_64
gluster-nagios-common-0.2.3-1.el6rhs.noarch
glusterfs-3.7.5-11.el6rhs.x86_64
glusterfs-fuse-3.7.5-11.el6rhs.x86_64
glusterfs-cli-3.7.5-11.el6rhs.x86_64
glusterfs-geo-replication-3.7.5-11.el6rhs.x86_64
python-gluster-3.7.5-11.el6rhs.noarch
gluster-nagios-addons-0.2.5-1.el6rhs.x86_64
glusterfs-libs-3.7.5-11.el6rhs.x86_64
glusterfs-api-3.7.5-11.el6rhs.x86_64
glusterfs-rdma-3.7.5-11.el6rhs.x86_64
[root@dhcp37-136 yum.repos.d]# 
[root@dhcp37-136 yum.repos.d]# 
[root@dhcp37-136 yum.repos.d]# rpm -qa | grep vdsm
vdsm-xmlrpc-4.16.30-1.2.el6rhs.noarch
vdsm-yajsonrpc-4.16.30-1.2.el6rhs.noarch
vdsm-gluster-4.16.30-1.2.el6rhs.noarch
vdsm-python-4.16.30-1.2.el6rhs.noarch
vdsm-cli-4.16.30-1.2.el6rhs.noarch
vdsm-jsonrpc-4.16.30-1.2.el6rhs.noarch
vdsm-reg-4.16.30-1.2.el6rhs.noarch
vdsm-python-zombiereaper-4.16.30-1.2.el6rhs.noarch
vdsm-4.16.30-1.2.el6rhs.x86_64
[root@dhcp37-136 yum.repos.d]# 
[root@dhcp37-136 yum.repos.d]# 

=============================================================

After adding the node to RHSC:

[root@dhcp37-136 yum.repos.d]# tuned-adm list
Available profiles:
- desktop-powersave
- rhgs-random-io
- virtual-host
- latency-performance
- rhgs-sequential-io
- laptop-battery-powersave
- rhs-high-throughput
- virtual-guest
- spindown-disk
- enterprise-storage
- server-powersave
- rhs-virtualization
- laptop-ac-powersave
- throughput-performance
- default
Current active profile: rhgs-sequential-io
[root@dhcp37-136 yum.repos.d]# 
============================================================


For Rhel7.2 Hosts:
++++++++++++++++++
[root@dhcp37-62 yum.repos.d]# rpm -qa | grep gluster
glusterfs-client-xlators-3.7.5-11.el7rhgs.x86_64
glusterfs-geo-replication-3.7.5-11.el7rhgs.x86_64
glusterfs-devel-3.7.5-11.el7rhgs.x86_64
nfs-ganesha-gluster-2.2.0-11.el7rhgs.x86_64
gluster-nagios-common-0.2.3-1.el7rhgs.noarch
glusterfs-libs-3.7.5-11.el7rhgs.x86_64
glusterfs-fuse-3.7.5-11.el7rhgs.x86_64
glusterfs-api-devel-3.7.5-11.el7rhgs.x86_64
python-gluster-3.7.5-11.el7rhgs.noarch
vdsm-gluster-4.16.30-1.1.el7rhgs.noarch
glusterfs-3.7.5-11.el7rhgs.x86_64
glusterfs-cli-3.7.5-11.el7rhgs.x86_64
glusterfs-ganesha-3.7.5-11.el7rhgs.x86_64
gluster-nagios-addons-0.2.5-1.el7rhgs.x86_64
glusterfs-server-3.7.5-11.el7rhgs.x86_64
glusterfs-api-3.7.5-11.el7rhgs.x86_64
glusterfs-rdma-3.7.5-11.el7rhgs.x86_64
[root@dhcp37-62 yum.repos.d]# 
[root@dhcp37-62 yum.repos.d]# 
[root@dhcp37-62 yum.repos.d]# rpm -qa | grep vdsm
vdsm-jsonrpc-4.16.30-1.1.el7rhgs.noarch
vdsm-xmlrpc-4.16.30-1.1.el7rhgs.noarch
vdsm-reg-4.16.30-1.1.el7rhgs.noarch
vdsm-python-zombiereaper-4.16.30-1.1.el7rhgs.noarch
vdsm-cli-4.16.30-1.1.el7rhgs.noarch
vdsm-yajsonrpc-4.16.30-1.1.el7rhgs.noarch
vdsm-gluster-4.16.30-1.1.el7rhgs.noarch
vdsm-4.16.30-1.1.el7rhgs.x86_64
vdsm-python-4.16.30-1.1.el7rhgs.noarch
[root@dhcp37-62 yum.repos.d]# 
[root@dhcp37-62 yum.repos.d]# 
[root@dhcp37-62 yum.repos.d]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)
[root@dhcp37-62 yum.repos.d]# 
[root@dhcp37-62 yum.repos.d]# cat /etc/redhat-storage-release 
Red Hat Gluster Storage Server 3.1 Update 2
[root@dhcp37-62 yum.repos.d]# 
[root@dhcp37-62 yum.repos.d]# 


[root@dhcp37-62 ~]# cat /etc/redhat-storage-release 
Red Hat Gluster Storage Server 3.1 Update 2
[root@dhcp37-62 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)
[root@dhcp37-62 ~]# 
[root@dhcp37-62 ~]# tuned-adm list
Available profiles:
- balanced
- desktop
- latency-performance
- network-latency
- network-throughput
- powersave
- rhgs-random-io
- rhgs-sequential-io
- throughput-performance
- virtual-guest
- virtual-host
Current active profile: virtual-guest
[root@dhcp37-62 ~]# 


================================================
After adding the host to RHSC:

[root@dhcp37-62 yum.repos.d]# tuned-adm list
Available profiles:
- balanced
- desktop
- latency-performance
- network-latency
- network-throughput
- powersave
- rhgs-random-io
- rhgs-sequential-io
- throughput-performance
- virtual-guest
- virtual-host
Current active profile: rhgs-random-io

[root@dhcp37-62 yum.repos.d]#
Comment 15 errata-xmlrpc 2016-03-01 01:10:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.