Bug 1259415 - [Docs] [Director] Scenerio 2 of insturctions ask to use heat template that calls baremetal flavor without being told to create baremetal flavor.
[Docs] [Director] Scenerio 2 of insturctions ask to use heat template that ca...
Status: CLOSED DUPLICATE of bug 1252452
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y1
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 10:27 EDT by Jeremy
Modified: 2015-09-08 00:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 00:29:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2015-09-02 10:27:33 EDT
Description of problem: Documentation Bug.

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/chap-Installing_the_Overcloud.html#sect-Accessing_the_Director

The instructions above ask you to use a heat template that calls on a baremetal flavor. However in scenario 2 you are not asked to create a baremetal flavor. The baremetal flavor is created in scenario 1(gui install). So overcloud deployment will fail since there is no baremetal flavor.


in step 6.2.5.2. Creating a Basic Overcloud Network Environment Template:
both of the following templates use baremetal flavors.

 OS::TripleO::ObjectStorage::Net::SoftwareConfig: /home/stack/templates/nic-configs/swift-storage.yaml
  OS::TripleO::CephStorage::Net::SoftwareConfig: /home/stack/templates/nic-configs/ceph-storage.yaml

Version-Release number of selected component (if applicable):7.0 dirctor


How reproducible:
100

Steps to Reproduce:
1.Follow documentation
2.
3.

Actual results:
failed overcloud deployment

Expected results:
success

Additional info:
Comment 3 Andrew Dahms 2015-09-03 02:45:20 EDT
Assigning to Dan for review.
Comment 4 Dan Macpherson 2015-09-08 00:29:22 EDT
Hi Jeremy,

I've got a bug open for this already and a fix is currently being implemented. I've added your email address and the Customer Portal case ID to the existing bug.

*** This bug has been marked as a duplicate of bug 1252452 ***

Note You need to log in before you can comment on or make changes to this bug.