Bug 1252452 - [Director] Cannot deploy overcloud, because of missing baremetal flavor.
[Director] Cannot deploy overcloud, because of missing baremetal flavor.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: z1
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation, ZStream
: 1255817 1259415 (view as bug list)
Depends On:
Blocks: 1264236
  Show dependency treegraph
 
Reported: 2015-08-11 09:06 EDT by Dariusz Smigiel
Modified: 2015-10-12 00:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 00:19:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
overcloud deployment logs (618.37 KB, text/plain)
2015-08-11 09:06 EDT, Dariusz Smigiel
no flags Details
heat templates (86.62 KB, application/x-gzip)
2015-08-11 09:07 EDT, Dariusz Smigiel
no flags Details

  None (edit)
Description Dariusz Smigiel 2015-08-11 09:06:11 EDT
Created attachment 1061517 [details]
overcloud deployment logs

Description of problem:
Following OSP7 documentation [1], deployment fails because there is missing baremetal flavor.

I'm using Scenario 3: Using the CLI to Create an Advanced Overcloud with Ceph Nodes with 3xController, 3xCompute, 3xStorage, preparing just Ceph nodes, without attaching Swift and Cinder.

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Advanced-Scenario_3_Using_the_CLI_to_Create_an_Advanced_Overcloud_with_Ceph_Nodes.html
Comment 3 Dariusz Smigiel 2015-08-11 09:07:28 EDT
Created attachment 1061518 [details]
heat templates
Comment 4 chris alfonso 2015-08-18 15:04:23 EDT
There is a step that should be documented in which you create the flavor. We'll get the docs fixed.
Comment 5 Andrew Dahms 2015-08-24 07:20:12 EDT
Dear Dariusz,

Thank you for raising this bug.

Now assigning to the author of the director content for review.

Dan - could you take a look at the above?

Kind regards,

Andrew
Comment 7 Alexander Chuzhoy 2015-08-26 14:38:17 EDT
another w/a is to pass "--compute-flavor compute --control-flavor control --ceph-storage-flavor compute --swift-storage-flavor compute --block-storage-flavor compute" ,thus specifying an existing flavor (manually created it) for the other roles.
Comment 8 Dan Macpherson 2015-09-08 00:13:32 EDT
*** Bug 1255817 has been marked as a duplicate of this bug. ***
Comment 9 Dan Macpherson 2015-09-08 00:29:22 EDT
*** Bug 1259415 has been marked as a duplicate of this bug. ***
Comment 11 Dariusz Smigiel 2015-09-09 01:38:46 EDT
For me, looks solid. Thanks

Note You need to log in before you can comment on or make changes to this bug.