Bug 1259426 - dnf-plugin-spacewalk doesn't work on Fedora 23
dnf-plugin-spacewalk doesn't work on Fedora 23
Status: CLOSED DUPLICATE of bug 1286555
Product: Fedora
Classification: Fedora
Component: dnf-plugin-spacewalk (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
:
Depends On: 1259884 1395864
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 10:55 EDT by Pavel Studeník
Modified: 2016-11-16 16:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 02:14:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2015-09-02 10:55:55 EDT
Description of problem:
I tried to run this plugin on Fedora 23 and it is not possible.

Version-Release number of selected component (if applicable):
dnf-plugin-spacewalk-2.4.15-1.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf install rhn-setup
2. dnf repolist
3. tail /var/log/dnf.log

Actual results:
Failed loading plugin: spacewalk


Expected results:
without error

Additional info:
==> /var/log/dnf.log <==
Sep 02 10:49:58 ERROR Failed loading plugin: spacewalk
Sep 02 10:49:58 SUBDEBUG
Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/dnf/plugin.py", line 124, in import_modules
    module = importlib.import_module(name)
  File "/usr/lib64/python3.4/importlib/__init__.py", line 109, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 2254, in _gcd_import
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1471, in exec_module
  File "<frozen importlib._bootstrap>", line 321, in _call_with_frames_removed
  File "/usr/lib/python3.4/site-packages/dnf-plugins/spacewalk.py", line 34, in <module>
    import up2date_client.up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 3, in <module>
    import rhnserver
ImportError: No module named 'rhnserver'
Comment 1 Michael Mráka 2016-02-12 02:14:44 EST

*** This bug has been marked as a duplicate of bug 1286555 ***

Note You need to log in before you can comment on or make changes to this bug.