Bug 1259434 - Network changes cause authentication token timeouts (Evolution)
Network changes cause authentication token timeouts (Evolution)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1395728
  Show dependency treegraph
 
Reported: 2015-09-02 11:09 EDT by Mikhail
Modified: 2017-03-07 14:09 EST (History)
12 users (show)

See Also:
Fixed In Version: gnome-online-accounts-3.18.3-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1395728 (view as bug list)
Environment:
Last Closed: 2015-12-20 01:52:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 751524 None None None 2015-12-17 05:12 EST

  None (edit)
Description Mikhail 2015-09-02 11:09:52 EDT
Description of problem:
Google Mail was configured  through gnome online accounts.
evolution can't connect to google mail, but online accounts show that all fine.

Demonstration: https://drive.google.com/file/d/0B0nwzlfiB4aQUzh5MmZ4cldnRHM/view?usp=sharing
Comment 1 Mikhail 2015-09-02 11:11:22 EDT
p.s. Empathy and Nautilus also can't connect to Google Services.
Comment 2 Milan Crha 2015-09-02 11:33:45 EDT
Thanks for a bug report. As this is not unique for the evolution, I'm moving the bug to gnome-online-accounts. Could you provide the version of the
gnome-online-accounts package, please?
Comment 3 Mikhail 2015-09-02 11:36:27 EDT
$ rpm -q gnome-online-accounts
gnome-online-accounts-3.17.2-2.fc23.x86_64
Comment 4 Beshoy 2015-11-11 17:02:55 EST
I am experiencing this as well.  Evolution can't access any of my gmail accounts.  I have tried removing and re-adding accounts to no avail.  I tried deleting the evolution directory in `~/.cache` and `~/.local` but no change.
Comment 5 Milan Crha 2015-11-12 08:41:47 EST
This error is due to a time outed call to goa-daemon process, which belongs to gnome-online-accounts. Try to restart that daemon and see what it does. Even before that, check in Online Accounts of the Settings whether all the accounts are fine.

If you've many calendars, address books, tasks list on the server, then each of them can try to access the password, which makes goa starve the request for some of them, causing the timeout.
Comment 6 Beshoy 2015-11-12 13:32:02 EST
I have four Google accounts and one Facebook account.  I had evolution set to request updates every minute.  I'm on Fedora 23 and don't see gnome-online-accounts in ps aux so I'm not sure how to restart it but this issue has persisted through several reboots and even on first load of evolution, the errors are there.
Comment 7 Andrew Dingman 2015-12-15 15:51:04 EST
I think this may be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1260401

Beshoy, the process you are looking for is "goa-daemon", not "gnome online accounts". You can try the test suggested in comment 5 by running '/usr/libexec/goa-daemon --replace'
Comment 8 Andrew Dingman 2015-12-15 16:17:28 EST
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=759515
Comment 9 Fedora Update System 2015-12-17 07:11:34 EST
gnome-online-accounts-3.18.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-a7c1115925
Comment 10 Fedora Update System 2015-12-18 06:55:57 EST
gnome-online-accounts-3.18.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-online-accounts'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a7c1115925
Comment 11 Andrew Dingman 2015-12-18 17:14:48 EST
Yesterday, I updated both my personal and work systems with the Koji update mentioned above, and ran /usr/libexec/goa-daemon --replace. Today, I am still seeing the "Failed to authenticate: Timeout was reached" messages from Evolution trying to access GMail accounts.
Comment 12 Fedora Update System 2015-12-20 01:52:08 EST
gnome-online-accounts-3.18.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Aidan Delaney 2016-08-28 05:46:32 EDT
Just FYI, I'm seeing the same issue on F24 with goa-daemon version 3.20.2 and evo 3.20.4.
Comment 14 N. Harrison Ripps 2016-09-07 11:41:25 EDT
(In reply to Aidan Delaney from comment #13)
> Just FYI, I'm seeing the same issue on F24 with goa-daemon version 3.20.2
> and evo 3.20.4.

Seconded. I am running:

$ rpm -q gnome-online-accounts
gnome-online-accounts-3.20.3-1.fc24.x86_64

and:

$ rpm -q evolution
evolution-3.20.5-1.fc24.x86_64

Please reopen this bug or point me in the right direction for opening this against F24.
Comment 15 Debarshi Ray 2016-09-13 07:54:45 EDT
Here are some ways to poke at gnome-online-accounts issues:
https://wiki.gnome.org/Projects/GnomeOnlineAccounts/Debugging
Comment 16 Gustavo Ferreira 2016-10-25 03:12:00 EDT
Hello,

I would like to report the same issue in Fedora 24.

$ rpm -q gnome-online-accounts 
gnome-online-accounts-3.20.2-1.fc24.x86_64

$ rpm -q evolution
evolution-3.20.4-1.fc24.x86_64

Note You need to log in before you can comment on or make changes to this bug.