Bug 1259474 - python-setuptools missing provides for python2-setuptools
python-setuptools missing provides for python2-setuptools
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-setuptools (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Charalampos Stratakis
Jakub Heger
: EasyFix, FastFix
: 1284754 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 12:38 EDT by Carl George
Modified: 2017-08-01 08:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-setuptools-0.9.8-6.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1420362 (view as bug list)
Environment:
Last Closed: 2017-08-01 08:14:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl George 2015-09-02 12:38:48 EDT
Description of problem:
The latest Fedora Python Packaging guidelines [1] state that python modules should have a virtual provides for python2-%{srcname}.  Obviously RHEL is not Fedora, but I think this enhancement makes sense for the RHEL package as well.  Similar virtual provides already exist on the base python packages.

    $ rpm -q --provides python | grep ^python2
    python2 = 2.7.5
    $ rpm -q --provides python-devel | grep ^python2
    python2-devel = 2.7.5-18.el7_1.1

Benefits:
EPEL package maintainers (like myself) can require the virtual python2 name in our spec files.  This allows the same spec file to be used for both Fedora and EPEL.

Drawbacks:
None that I am aware of.

Version-Release number of selected component (if applicable):
0.9.8-3.el7

Actual results:
python-setuptools does not provide python2-setuptools

Expected results:
python-setuptools should provide python2-setuptools

Additional info:
[1]: http://fedoraproject.org/wiki/Packaging:Python#Provides
Comment 2 Alan Pevec 2015-12-07 20:00:04 EST
*** Bug 1284754 has been marked as a duplicate of this bug. ***
Comment 3 Orion Poplawski 2016-05-10 17:59:46 EDT
This would help a lot with Fedora EPEL package consistency.
Comment 4 Orion Poplawski 2016-10-24 18:58:06 EDT
Really disappointed that this does not appear to have made it into 7.3.
Comment 7 Jakub Heger 2017-02-08 09:11:36 EST
Verified
Reproduced on version: python-setuptools-0.6.10-3.el6.noarch
Verified on version: python-setuptools-0.9.8-6.el7.noarch

Reproducer: rpm -q --provides python-setuptools | grep python2
Comment 8 errata-xmlrpc 2017-08-01 08:14:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1900

Note You need to log in before you can comment on or make changes to this bug.