Bug 1259564 - rabbitmq-server stops (instead of restart) during update to rabbitmq-server-3.3.5-5.el7.noarch
rabbitmq-server stops (instead of restart) during update to rabbitmq-server-3...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: rabbitmq-server (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Eckersberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 01:00 EDT by Ivan Mironov
Modified: 2015-09-25 15:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.5.4-3.fc23 rabbitmq-server-3.5.4-3.fc22 rabbitmq-server-3.3.5-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1264083 (view as bug list)
Environment:
Last Closed: 2015-09-18 14:37:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Mironov 2015-09-03 01:00:35 EDT
Description of problem:
During update to rabbitmq-server-3.3.5-5.el7.noarch, rabbitmq-server service stops, while it should be restarted.

/var/log/yum.log:
    ...
    Sep 03 07:42:06 Updated: rabbitmq-server-3.3.5-5.el7.noarch
    ...

journalctl -u rabbitmq-server:
    ...
    Sep 03 07:41:59 devenv-msk-09 systemd[1]: Stopping RabbitMQ broker...
    Sep 03 07:41:59 devenv-msk-09 rabbitmqctl[29552]: Stopping and halting node 'rabbit@devenv-msk-09' ...
    Sep 03 07:42:05 devenv-msk-09 rabbitmqctl[29552]: ...done.
    Sep 03 07:42:05 devenv-msk-09 systemd[1]: Stopped RabbitMQ broker.

Version-Release number of selected component (if applicable):
rabbitmq-server-3.3.5-5.el7.noarch


How reproducible:
This happened on two different servers.


Steps to Reproduce:
1. Install previous version of rabbitmq-server
2. systemctl enable rabbitmq-server && systemctl start rabbitmq-server
3. Update using yum


Actual results:
rabbitmq-server is not running after update.


Expected results:
rabbitmq-server should be up and running.


Additional info:
N/A
Comment 1 Fedora Update System 2015-09-03 12:12:38 EDT
rabbitmq-server-3.5.4-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15005
Comment 2 Fedora Update System 2015-09-03 12:17:32 EDT
rabbitmq-server-3.5.4-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15009
Comment 3 Fedora Update System 2015-09-03 12:21:30 EDT
rabbitmq-server-3.3.5-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7918
Comment 4 John Eckersberg 2015-09-03 12:26:19 EDT
The fix here is to:

1) remove service stop from %pre
2) add service try-restart in %postun

Which means that upgrading to the fixed package will not stop the service, but it also will not restart the service because the old package does not have the %postun scriptlet.

However, all future upgrades after the first will contain the %postun scriptlet and will restart properly.
Comment 5 Fedora Update System 2015-09-04 03:29:32 EDT
rabbitmq-server-3.5.4-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update rabbitmq-server'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15009
Comment 6 Fedora Update System 2015-09-04 03:33:36 EDT
rabbitmq-server-3.5.4-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update rabbitmq-server'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15005
Comment 7 Fedora Update System 2015-09-04 15:17:44 EDT
rabbitmq-server-3.3.5-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update rabbitmq-server'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7918
Comment 8 Fedora Update System 2015-09-18 14:37:06 EDT
rabbitmq-server-3.5.4-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-09-25 06:54:14 EDT
rabbitmq-server-3.5.4-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-09-25 15:54:55 EDT
rabbitmq-server-3.3.5-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.