Bug 1264083 - rabbitmq-server stops (instead of restart) during update
rabbitmq-server stops (instead of restart) during update
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: async
: 7.0 (Kilo)
Assigned To: Peter Lemenkov
nlevinki
: Triaged, ZStream
: 1264688 1271664 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 09:13 EDT by John Eckersberg
Modified: 2016-04-26 23:54 EDT (History)
13 users (show)

See Also:
Fixed In Version: rabbitmq-server-3.3.5-6.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the rabbitmq-server service was stopped when the rabbitmq-server package was updated. Now, the service is conditionally restarted after an update is applied and before the traces of the previous version are removed. As a result, updating to this version does not yet restart the service because the previous package does not yet contain the necessary command; however, with future updates, the service will (conditionally) restart automatically.
Story Points: ---
Clone Of: 1259564
Environment:
Last Closed: 2015-11-19 18:30:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2015-09-17 09:13:12 EDT
+++ This bug was initially created as a clone of Bug #1259564 +++

Description of problem:
During update to rabbitmq-server-3.3.5-5.el7.noarch, rabbitmq-server service stops, while it should be restarted.

/var/log/yum.log:
    ...
    Sep 03 07:42:06 Updated: rabbitmq-server-3.3.5-5.el7.noarch
    ...

journalctl -u rabbitmq-server:
    ...
    Sep 03 07:41:59 devenv-msk-09 systemd[1]: Stopping RabbitMQ broker...
    Sep 03 07:41:59 devenv-msk-09 rabbitmqctl[29552]: Stopping and halting node 'rabbit@devenv-msk-09' ...
    Sep 03 07:42:05 devenv-msk-09 rabbitmqctl[29552]: ...done.
    Sep 03 07:42:05 devenv-msk-09 systemd[1]: Stopped RabbitMQ broker.

Version-Release number of selected component (if applicable):
rabbitmq-server-3.3.5-5.el7.noarch


How reproducible:
This happened on two different servers.


Steps to Reproduce:
1. Install previous version of rabbitmq-server
2. systemctl enable rabbitmq-server && systemctl start rabbitmq-server
3. Update using yum


Actual results:
rabbitmq-server is not running after update.


Expected results:
rabbitmq-server should be up and running.


Additional info:
N/A

--- Additional comment from Fedora Update System on 2015-09-03 12:12:38 EDT ---

rabbitmq-server-3.5.4-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15005

--- Additional comment from Fedora Update System on 2015-09-03 12:17:32 EDT ---

rabbitmq-server-3.5.4-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15009

--- Additional comment from Fedora Update System on 2015-09-03 12:21:30 EDT ---

rabbitmq-server-3.3.5-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7918

--- Additional comment from John Eckersberg on 2015-09-03 12:26:19 EDT ---

The fix here is to:

1) remove service stop from %pre
2) add service try-restart in %postun

Which means that upgrading to the fixed package will not stop the service, but it also will not restart the service because the old package does not have the %postun scriptlet.

However, all future upgrades after the first will contain the %postun scriptlet and will restart properly.

--- Additional comment from Fedora Update System on 2015-09-04 03:29:32 EDT ---

rabbitmq-server-3.5.4-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update rabbitmq-server'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15009

--- Additional comment from Fedora Update System on 2015-09-04 03:33:36 EDT ---

rabbitmq-server-3.5.4-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update rabbitmq-server'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15005

--- Additional comment from Fedora Update System on 2015-09-04 15:17:44 EDT ---

rabbitmq-server-3.3.5-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update rabbitmq-server'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7918
Comment 3 John Eckersberg 2015-09-23 13:49:05 EDT
*** Bug 1264688 has been marked as a duplicate of this bug. ***
Comment 4 John Eckersberg 2015-09-23 13:52:16 EDT
Cleaning up Cc list that got pulled over when cloning Fedora bug...
Comment 6 Peter Lemenkov 2015-09-25 11:07:45 EDT
Taking this.
Comment 7 Mike Burns 2015-10-23 09:41:59 EDT
*** Bug 1271664 has been marked as a duplicate of this bug. ***
Comment 9 nlevinki 2015-11-19 02:22:13 EST
automation passed.
No issues were found
Comment 11 errata-xmlrpc 2015-11-19 18:30:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2496

Note You need to log in before you can comment on or make changes to this bug.