Bug 1259604 - New VM -> Instance images dialog behaves incorrectly when trying to cancel action.
New VM -> Instance images dialog behaves incorrectly when trying to cancel ac...
Status: CLOSED DUPLICATE of bug 1256003
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: nobody nobody
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 03:18 EDT by Nisim Simsolo
Modified: 2015-09-03 03:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 03:44:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nisim Simsolo 2015-09-03 03:18:32 EDT
Description of problem:
Cancelling new VM -> Instance images -> attach/create dialog is closing new VM dialog at all, instead of going back to new VM dialog.
Because new VM dialog page closed, the user need to enter all VM parameters again.
Also, after this issue occurred, new VM dialog cannot be opened unless the browser page is refreshed.

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.12.master.el6
qemu-kvm-rhev-2.3.0-21.el7.x86_64
vdsm-4.17.3-1.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-5.el7.x86_64

How reproducible:
Consistently

Steps to Reproduce:
1. Open New VM dialog
2. Select host (must for bug reproduction) and enter some other VM parameters.
3. From new VM -> general tab -> instance images, select create/attach and afterward click cancel.

Actual results:
New VM dialog page is closed.

Expected results:
attach/create dialog should be closed and new VM dialog should appear again with entered parameters.

Additional info:
Comment 1 Omer Frenkel 2015-09-03 03:44:11 EDT

*** This bug has been marked as a duplicate of bug 1256003 ***

Note You need to log in before you can comment on or make changes to this bug.