Bug 1256003 - Can't create new VMs with New disks
Can't create new VMs with New disks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
high Severity urgent
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Alexander Wels
Lukas Svaty
: AutomationBlocker, Regression
: 1256017 1256695 1259604 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 03:17 EDT by Michael Burman
Modified: 2016-04-19 21:30 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:30:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (114.64 KB, application/x-gzip)
2015-08-23 03:17 EDT, Michael Burman
no flags Details
felogs (15.88 KB, text/plain)
2015-08-24 04:13 EDT, Tomas Jelinek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45260 master MERGED webadmin: New Virtual disk npe Never
oVirt gerrit 45455 None None None Never

  None (edit)
Description Michael Burman 2015-08-23 03:17:27 EDT
Created attachment 1065990 [details]
logs

Description of problem:
It's not possible to create new VMs with disks on the create 'New Virtual Window' , when clicking on the 'ok' button, window just closed without any error or anything. VM is not created. 
All other parts of the Virtual Machines tab in the UI stop from responding until refreshing the browser.

Version-Release number of selected component (if applicable):
3.6.0-0.12.master.el6

How reproducible:
100

Steps to Reproduce:
1. Try to create new VM with new disk and press 'ok' to approve 


Actual results:
Nothing happens. VM is not created, no errors of failing.  
Virtual Machines main tab stops from responding, for example : 'new vm' , 'import' .

Expected results:
Should be able to create new VMs with disks on the create New Virtual Machine
Comment 3 Omer Frenkel 2015-08-24 02:09:41 EDT
*** Bug 1256017 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Jelinek 2015-08-24 04:13:02 EDT
Created attachment 1066240 [details]
felogs
Comment 5 Tomas Jelinek 2015-08-24 04:14:16 EDT
This regression has been introduced by the introduction of the 
org.ovirt.engine.ui.common.widget.editor.ListModelMultipleSelectListBox
- AFAIK Alex is already working on it - assigning to him.
Comment 6 Einav Cohen 2015-08-26 10:59:07 EDT
*** Bug 1256695 has been marked as a duplicate of this bug. ***
Comment 7 Einav Cohen 2015-08-30 10:05:04 EDT
master patch merged - need to backport to ovirt-engine-3.6.
Comment 8 Omer Frenkel 2015-09-03 03:44:11 EDT
*** Bug 1259604 has been marked as a duplicate of this bug. ***
Comment 9 Lukas Svaty 2015-09-16 09:49:09 EDT
verified in rhevm-webadmin-portal-3.6.0-0.15.master.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.