Bug 1259694 - Data Tiering:Regression:Commit of detach tier passes without directly without even issuing a detach tier start
Data Tiering:Regression:Commit of detach tier passes without directly without...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Gaurav Kumar Garg
bugs@gluster.org
:
Depends On:
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-03 07:43 EDT by nchilaka
Modified: 2016-06-05 19:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1260185 (view as bug list)
Environment:
Last Closed: 2015-10-14 06:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nchilaka 2015-09-03 07:43:55 EDT
Description of problem:
======================
Detach tier commit should not pass if there was no detach tier start triggered.
That should work only if force option is used clearly.
However, detach tier commit is passing even without detach tier start is triggered, which was not the case previously.
This is a regression.


[root@nag-manual-node1 /]# gluster v info vvs;gluster v status vvs
 
Volume Name: vvs
Type: Tier
Volume ID: 988d395c-be78-4d84-939b-eaad367f3504
Status: Started
Number of Bricks: 6
Transport-type: tcp
Hot Tier :
Hot Tier Type : Distribute
Number of Bricks: 2
Brick1: 10.70.46.36:/rhs/brick4/vvs1
Brick2: 10.70.46.84:/rhs/brick4/vvs1
Cold Tier:
Cold Tier Type : Distribute
Number of Bricks: 4
Brick3: 10.70.46.84:/rhs/brick1/vvs
Brick4: 10.70.46.36:/rhs/brick1/vvs
Brick5: 10.70.46.84:/rhs/brick2/vvs
Brick6: 10.70.46.36:/rhs/brick2/vvs
Options Reconfigured:
performance.readdir-ahead: on
Status of volume: vvs
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Hot Bricks:
Brick 10.70.46.36:/rhs/brick4/vvs1          49156     0          Y       15202
Brick 10.70.46.84:/rhs/brick4/vvs1          49156     0          Y       24052
Cold Bricks:
Brick 10.70.46.84:/rhs/brick1/vvs           49152     0          Y       23722
Brick 10.70.46.36:/rhs/brick1/vvs           49152     0          Y       14985
Brick 10.70.46.84:/rhs/brick2/vvs           49153     0          Y       23740
Brick 10.70.46.36:/rhs/brick2/vvs           49153     0          Y       15003
NFS Server on localhost                     2049      0          Y       24071
NFS Server on 10.70.46.36                   2049      0          Y       15221
 
Task Status of Volume vvs
------------------------------------------------------------------------------
Task                 : Rebalance           
ID                   : 034a03d3-f977-4a59-9c55-4a7d9cd429e8
Status               : in progress         
 
[root@nag-manual-node1 /]# gluster v detach-tier vvs commit
volume detach-tier commit: success
Check the detached bricks to ensure all files are migrated.
If files with data are found on the brick path, copy them via a gluster mount point before re-purposing the removed brick. 
[root@nag-manual-node1 /]# gluster v info vvs
 
Volume Name: vvs
Type: Distribute
Volume ID: 988d395c-be78-4d84-939b-eaad367f3504
Status: Started
Number of Bricks: 4
Transport-type: tcp
Bricks:
Brick1: 10.70.46.84:/rhs/brick1/vvs
Brick2: 10.70.46.36:/rhs/brick1/vvs
Brick3: 10.70.46.84:/rhs/brick2/vvs
Brick4: 10.70.46.36:/rhs/brick2/vvs
Options Reconfigured:
performance.readdir-ahead: on
[root@nag-manual-node1 /]# 


Version-Release number of selected component (if applicable):
================================================================
[root@nag-manual-node1 /]# rpm -qa|grep gluster
glusterfs-libs-3.7.4-0.16.git9f27ef9.el6.x86_64
glusterfs-api-3.7.4-0.16.git9f27ef9.el6.x86_64
glusterfs-client-xlators-3.7.4-0.16.git9f27ef9.el6.x86_64
glusterfs-fuse-3.7.4-0.16.git9f27ef9.el6.x86_64
glusterfs-cli-3.7.4-0.16.git9f27ef9.el6.x86_64
glusterfs-3.7.4-0.16.git9f27ef9.el6.x86_64
glusterfs-server-3.7.4-0.16.git9f27ef9.el6.x86_64
[root@nag-manual-node1 /]# gluster --version
glusterfs 3.7.4 built on Sep  2 2015 18:06:07
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.


How reproducible:
===================
everytime easily

Steps to Reproduce:
====================
1.create a volume, start it and attac tier to vol 
2.now issue a detach-tier <vname> commit 



Actual results:
================
commit detaches tier without even requiring a detach tier start

Expected results:
=================
commit should be allowed only after detach tier start is triggered




It was working previously. hence  a regression
Comment 1 Gaurav Kumar Garg 2015-09-04 12:50:07 EDT
upstream patch for this bug is available: http://review.gluster.org/#/c/12107/
Comment 2 Vijay Bellur 2015-09-04 13:21:57 EDT
REVIEW: http://review.gluster.org/12108 (glusterd: Do not allow "detach-tier commit" unnecessarily) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Vijay Bellur 2015-09-08 04:27:07 EDT
REVIEW: http://review.gluster.org/12108 (glusterd: Do not allow "detach-tier commit" unnecessarily) posted (#2) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Vijay Bellur 2015-09-09 20:06:21 EDT
COMMIT: http://review.gluster.org/12108 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 61a60de37e7fdfa0b9a9ec83c3edc7a94e4e0ed2
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Fri Sep 4 22:10:55 2015 +0530

    glusterd: Do not allow "detach-tier commit" unnecessarily
    
    Backport of: http://review.gluster.org/#/c/12107/
    
    Currently when user execute gluster v detach-tier commit command without
    starting detach-tier or without giving force option then gluster will
    success this operation.
    
    Detach-tier commit should not allow without giving "force" optioin.
    
        >>Reviewed-on: http://review.gluster.org/12107
        >>Tested-by: NetBSD Build System <jenkins@build.gluster.org>
        >>Tested-by: Gluster Build System <jenkins@build.gluster.com>
        >>Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
        >>Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Id161c288f6f3e0f6b298878a5c35a49fcbd9c6e3
    BUG: 1259694
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/12108
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Pranith Kumar K 2015-10-14 06:29:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 6 Pranith Kumar K 2015-10-14 06:38:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.