Bug 1259763 - Archive Manager is listed twice in Notifications list of Control Centerr
Archive Manager is listed twice in Notifications list of Control Centerr
Status: CLOSED DUPLICATE of bug 1259292
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: file-roller (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David King
Desktop QE
:
: 1259760 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 09:40 EDT by Vadim Rutkovsky
Modified: 2015-09-28 12:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 12:57:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Rutkovsky 2015-09-03 09:40:49 EDT
Description of problem:
Archive Manager is listed twice in Notifications list of Control Center

Version-Release number of selected component (if applicable):
control-center-3.14.5-8.el7.x86_64
file-roller-3.14.2-5.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Open Control Center
2. Open Notifications section

Actual results:
Archive Manager is present twice

Expected results:
List items should be unique

Additional info:
Comment 1 David King 2015-09-03 09:47:03 EDT
Probably due to the backwards-compatibility workaround in bug 1235413, which added a copy of the desktop file with an older name. This will probably be the case for all applications with duplicate (albeit NoDisplay) desktop files, so probably needs fixing either in gnome-control-center (to not show applications with NoDisplay set), or some other fix.
Comment 3 Matthias Clasen 2015-09-04 14:43:35 EDT
*** Bug 1259760 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2015-09-07 04:51:09 EDT
That's the "compat" desktop files:
* Fri Jun 26 2015 Ray Strode <rstrode@redhat.com> 3.14.2-3
- add NoDisplay desktop file for 3.8 desktop id to keep backward compat
  Related: #1174580 1235413

Ray did the same in totem (bug #1259292).
Comment 5 Matthias Clasen 2015-09-28 12:57:00 EDT

*** This bug has been marked as a duplicate of bug 1259292 ***

Note You need to log in before you can comment on or make changes to this bug.