Bug 1260034 - Specially crafted binary can cause readelf to read from an arbitrary address-
Summary: Specially crafted binary can cause readelf to read from an arbitrary address-
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: binutils
Version: DTS 4.1 RHEL 7
Hardware: All
OS: All
unspecified
low
Target Milestone: alpha
: 4.1
Assignee: Nick Clifton
QA Contact: Miloš Prchlík
URL:
Whiteboard:
Depends On:
Blocks: 1260035 1260158 1409817
TreeView+ depends on / blocked
 
Reported: 2015-09-04 09:28 UTC by Nick Clifton
Modified: 2017-01-03 14:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1260035 1409817 (view as bug list)
Environment:
Last Closed: 2016-05-31 08:43:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fuzzed binary that reproduces the seg-fault when processed with 'readelf -a' (5.80 KB, application/octet-stream)
2015-09-04 09:28 UTC, Nick Clifton
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1148 normal SHIPPED_LIVE devtoolset-4-binutils bug fix and enhancement update 2016-05-31 12:38:24 UTC
Sourceware 18879 None None None 2019-01-04 12:09:26 UTC

Description Nick Clifton 2015-09-04 09:28:33 UTC
Created attachment 1070188 [details]
Fuzzed binary that reproduces the seg-fault when processed with 'readelf -a'

Description of problem:

  Readelf can be fooled into attempting to read from an arbitrary memory location if it is run against a specially crafted binary.

Version-Release number of selected component (if applicable):

  All versions.

How reproducible:

  Run "readelf -a test00-min'

Actual results:

  seg-fault

Expected results:

  error message

Additional info:

  The bug has been fixed in the upstream FSF sources.  The patch can be found here:
 https://sourceware.org/bugzilla/show_bug.cgi?id=18879

Comment 1 Nick Clifton 2016-02-04 16:06:11 UTC
binutils-2.25.1-2.el7 contains a fix for this problem.

Comment 3 Miloš Prchlík 2016-03-08 09:00:03 UTC
Verified for build devtoolset-4-binutils-2.25.1-5.el7.

Comment 5 errata-xmlrpc 2016-05-31 08:43:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1148


Note You need to log in before you can comment on or make changes to this bug.