Bug 1409817 - Specially crafted binary can cause readelf to read from an arbitrary address-
Specially crafted binary can cause readelf to read from an arbitrary address-
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: binutils (Show other bugs)
6.9
All All
unspecified Severity low
: rc
: ---
Assigned To: Nick Clifton
Miloš Prchlík
:
Depends On: 1260034
Blocks: 1260035 1260158
  Show dependency treegraph
 
Reported: 2017-01-03 09:16 EST by Miloš Prchlík
Modified: 2017-03-21 06:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The readelf program assumed that it has been given a valid ELF input file to examine, and it did not check that this assumption was correct. Consequence: Passing a specially crafted, corrupt ELF file to readelf could cause it to attempt to read from address 0, resulting in readelf being terminated with a seg-fault error. Fix: Patch the readelf sources to add checks on the validity of the ELF section headers. Result: Readelf runs correctly, does not seg-fault and is able to display information on the corrupt input file.
Story Points: ---
Clone Of: 1260034
Environment:
Last Closed: 2017-03-21 06:32:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 18879 None None None 2017-01-03 09:16 EST
Red Hat Product Errata RHBA-2017:0677 normal SHIPPED_LIVE binutils bug fix update 2017-03-21 08:36:14 EDT

  None (edit)
Comment 2 Nick Clifton 2017-01-05 06:16:20 EST
I have checked in an alternative patch to fix this BZ.

The problem is that the patch for PR 18879 does not work with the RHEL 6.9
binutils sources, since this version of readelf does not actually have the
capability to dump unwind information.  In theory this should mean that the
bug fixed in PR 18879 is never encountered and so no patch is needed.  In
practice however it turns out that the test case for PR 18879 triggers a
*different* bug in the 6.9 binutils, and so a patch is needed after all.
Comment 4 Miloš Prchlík 2017-01-21 13:35:54 EST
Verified with build binutils-2.20.51.0.2-5.46.el6.
Comment 6 errata-xmlrpc 2017-03-21 06:32:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0677.html

Note You need to log in before you can comment on or make changes to this bug.