Bug 1260218 - Sat 6.1 filesystem reqs are not in agreement
Sat 6.1 filesystem reqs are not in agreement
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.1
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.2
Assigned To: Allison Heslin
Brandi
:
: 1244134 (view as bug list)
Depends On:
Blocks: 1122832
  Show dependency treegraph
 
Reported: 2015-09-04 15:40 EDT by Hayley Hudgeons
Modified: 2016-04-27 19:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 19:46:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayley Hudgeons 2015-09-04 15:40:40 EDT
>> From satellite-tech-list (Mike Persell - mpersell@redhat.com)

In reviewing the Satellite 6.1 guides the documentation says "minimum of
2GB" for /var/lib/pgsql in one space, but then in another it says "100MB
to 250MB" further down the page.  It says "minimum 20GB for each unique
software repository" in one spot, citing /var/lib/mongodb and
/var/lib/pulp, but then shows  200GB for /var/lib/pulp and 15GB for
/var/lib/mongodb under "runtime requirements with Red Hat Enterprise
Linux 5/6/7 synchronized" down below... which is far more space than
60GB combined for the "minimum" suggested above.

---
Looking into this further:

>> [1.4.3. Storage] states: 
"A minimum of 2 GB of available storage in /var/lib/pgsql with the ability to grow the partition containing this directory as data storage requirements grow."

>> [Table 1.2. Recommended Storage Considerations] states:
 /var/lib/pgsql 
- installation size requirement:  100 MB 
- runtime requirement:  250 MB 

--
>> [1.4.3. Storage] states: 
"A minimum of 20 GB storage for each unique software repository [...] The bulk of storage resides on the /var/lib/mongodb and /var/lib/pulp directories."

>> [Table 1.2. Recommended Storage Considerations] states:
 /var/lib/pgsql 
- installation size requirement:   1 MB 
- runtime requirement:   200 GB  


This needs some clarification.
Comment 1 Hayley Hudgeons 2015-09-22 15:18:51 EDT
*** Bug 1244134 has been marked as a duplicate of this bug. ***
Comment 2 Hayley Hudgeons 2015-09-22 15:20:09 EDT
Additional notes from duplicate [closed] bug:

>> Describe the issue: 
- Storage recommendations are is not consistent and some information is duplicated
- pgsql mentions also partition needs to grow, this is also mentioned in the buller of pulp and a third time in the Note below
- pulp mentioned 20G per software repo. Below in the table it is mentioed to need 200GB for RHEL5/6/7. What is a "software repo"? 20 -> 200 is a factor 10. This is not explained.

>> Suggestions for improvement: 
- Align the content on usage of /var
- Is it not better to recommend to have the pulp, mongodb, log, pgsql on a different LV to make sure that the database integrity is kept once the pulp of log goes full?
- Provide better calculation schema for the Storage sizing:
  - Define with is a Software Repo
  - How many Software Repos are included in
  - Include de-duplication factor of the shared RPM content directory, e.g. sync 6.5,6.6 and 6Server has a good de-duplication.
Comment 3 mertensb 2016-01-20 07:07:40 EST
Another BZ that is related: https://bugzilla.redhat.com/show_bug.cgi?id=1292801

Other directories that should be mentioned because they can grow quite big:
/var/lib/qpidd/ (apparently this cannot be shrinked down (nearly 6GB in our setup now - after long time issues with certificates so this may not be representative)

/var/log: again depends on the amount of errors encountered but this is more than on other RHEL systems as well

All in all /var consumes 11GB now while we originally provisioned 3.


/var/lib/mongodb is now 35GB (20GB in use) compared to the 15GB recommended in the installation guide.

/var/lib/pulp is now 355GB (264GB in use) with RHEL5 (64bit), RHEL6, RHEL7 and EPEL5, EPEL6 and EPEL7 and puppetforge synced.

Again part of the problem may be related to problems we encountered (e.g. https://access.redhat.com/solutions/2077993) but it seems that satellite 6.1 needs a lot more storage than explained in the installation guide.

Regards

Bram
Comment 6 Allison Heslin 2016-02-19 09:35:17 EST
Per email conversation with Mike McCune:

* Add same consideration under /var/lib/pulp as you have for 
/var/lib/mongodb

"Will continue to grow as content is added to Satellite Server. Plan for 
expansion over time."

As far as the debug repo in storage requirements, I'm not quite sure 
what he is getting at as debug repos aren't something that many people 
utilize in Sat 6.

also got an ACK and +1 to the RHEL7 blurbs you added, thanks for that.


otherwise, looks great

My question:
As a related question, I met with GSS yesterday to review the Install Guide. He mentioned adding the debug repo in the storage requirements and that it can get big. Is that something that I need to add? If so, what's the minimum size?
Comment 7 Andrew Dahms 2016-04-27 19:46:24 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.