Bug 1260257 - tracer: AttributeError: 'module' object has no attribute 'get_pid_list'
tracer: AttributeError: 'module' object has no attribute 'get_pid_list'
Status: CLOSED DUPLICATE of bug 1260302
Product: Fedora
Classification: Fedora
Component: tracer (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-09-05 04:29 EDT by Lukas Slebodnik
Modified: 2015-09-08 06:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-08 06:11:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2015-09-05 04:29:32 EDT
Description of problem:
It cannot be execute. There is a python stack trace after invokation.

[root@host bin]# tracer -a
Traceback (most recent call last):
  File "/usr/bin/tracer", line 34, in <module>
  File "/usr/lib/python2.7/site-packages/tracer/main.py", line 42, in run
    return router.dispatch()
  File "/usr/lib/python2.7/site-packages/tracer/resources/router.py", line 55, in dispatch
    controller = DefaultController(self.args, self.packages)
  File "/usr/lib/python2.7/site-packages/tracer/controllers/default.py", line 46, in __init__
    self.applications = self.tracer.trace_affected(self._user(args.user))
  File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 80, in trace_affected
    memory = self._memory(user)
  File "/usr/lib/python2.7/site-packages/tracer/resources/memory.py", line 36, in dump_memory
    for process in Processes.all().owned_by(user).unique():
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 32, in all
    for pid in psutil.get_pid_list():
AttributeError: 'module' object has no attribute 'get_pid_list'

Version-Release number of selected component (if applicable):
sh$ rpm -q tracer

How reproducible:

Steps to Reproduce:
1. execute "tracer -a"
Comment 1 Jakub Kadlčík 2015-09-08 06:11:40 EDT
Hello Lukas,
thank you for the feedback.

This issue is duplicate of 1260302 so please see the progress there.

*** This bug has been marked as a duplicate of bug 1260302 ***

Note You need to log in before you can comment on or make changes to this bug.