Bug 1260302 - python2-psutil.x86_64 3.2.1-2.fc23 killed tracer
python2-psutil.x86_64 3.2.1-2.fc23 killed tracer
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tracer (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
:
: 1260257 1260362 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 16:02 EDT by Paul Sand
Modified: 2015-09-24 10:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.6.6-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 01:13:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Sand 2015-09-05 16:02:37 EDT
Description of problem:

"tracer" no longer works after python2-psutil upgrade

Version-Release number of selected component (if applicable):

tracer-0.5.9-3.fc23.noarch

How reproducible:

Run "tracer" on an upgraded F23 system

Steps to Reproduce:
1. Install today's (9/5/2015) updates, including python2-psutil
2. Run tracer
3. Observe errors

Actual results:

Traceback (most recent call last):
  File "/usr/bin/tracer", line 34, in <module>
    tracer.main.run()
  File "/usr/lib/python2.7/site-packages/tracer/main.py", line 42, in run
    return router.dispatch()
  File "/usr/lib/python2.7/site-packages/tracer/resources/router.py", line 55, in dispatch
    controller = DefaultController(self.args, self.packages)
  File "/usr/lib/python2.7/site-packages/tracer/controllers/default.py", line 46, in __init__
    self.applications = self.tracer.trace_affected(self._user(args.user))
  File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 80, in trace_affected
    memory = self._memory(user)
  File "/usr/lib/python2.7/site-packages/tracer/resources/memory.py", line 36, in dump_memory
    for process in Processes.all().owned_by(user).unique():
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 32, in all
    for pid in psutil.get_pid_list():
AttributeError: 'module' object has no attribute 'get_pid_list'


Expected results:

Normal tracer output, telling me whether I need to reboot.

Additional info:

I'm just guessing about the python2-psutil package being the culprit here, since that's in the tracer dependencies, and tracer seemed to be working  before it was upgraded.
Comment 1 Jakub Kadlčík 2015-09-08 06:11:40 EDT
*** Bug 1260257 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Kadlčík 2015-09-08 06:12:57 EDT
*** Bug 1260362 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Kadlčík 2015-09-08 06:36:11 EDT
Hello Paul,
thank you for the feedback.

This issue was actually fixed in 2ce501a which is tracer-0.6.3 but the problem is, that I forgot to release updates for Fedora 23.

I am going to release tracer-0.6.6 as far as possible. Please give it karma, if it will work for you.
Comment 4 Fedora Update System 2015-09-08 06:42:20 EDT
tracer-0.6.6-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15324
Comment 5 Fedora Update System 2015-09-08 06:42:31 EDT
tracer-0.6.6-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15325
Comment 6 Fedora Update System 2015-09-08 06:44:40 EDT
tracer-0.6.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15326
Comment 7 Fedora Update System 2015-09-08 13:51:20 EDT
tracer-0.6.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tracer'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15326
Comment 8 Fedora Update System 2015-09-08 17:21:55 EDT
tracer-0.6.6-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tracer'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15325
Comment 9 Fedora Update System 2015-09-08 17:25:48 EDT
tracer-0.6.6-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tracer'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15324
Comment 10 Fedora Update System 2015-09-24 01:13:28 EDT
tracer-0.6.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-09-24 04:25:32 EDT
tracer-0.6.6-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-09-24 10:19:09 EDT
tracer-0.6.6-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.