Bug 1260318 - TypeError: uid should be integer, not str
TypeError: uid should be integer, not str
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:71ba50b06bb7b6a4ab4c4be298e...
:
: 1260396 1261072 (view as bug list)
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-09-05 19:38 EDT by Piotr Drąg
Modified: 2015-09-16 14:35 EDT (History)
14 users (show)

See Also:
Fixed In Version: 23.19.4-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 14:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.38 MB, text/plain)
2015-09-05 19:38 EDT, Piotr Drąg
no flags Details
File: anaconda.log (53.11 KB, text/plain)
2015-09-05 19:38 EDT, Piotr Drąg
no flags Details
File: environ (615 bytes, text/plain)
2015-09-05 19:38 EDT, Piotr Drąg
no flags Details
File: journalctl (808.23 KB, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details
File: lsblk_output (3.90 KB, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details
File: nmcli_dev_list (2.57 KB, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details
File: os_info (518 bytes, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details
File: program.log (157.05 KB, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details
File: storage.log (287.04 KB, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details
File: ifcfg.log (9.08 KB, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details
File: packaging.log (131 bytes, text/plain)
2015-09-05 19:39 EDT, Piotr Drąg
no flags Details

  None (edit)
Description Piotr Drąg 2015-09-05 19:38:45 EDT
Description of problem:
Anaconda crashed when finishing installing. Live USB workstation from 2015-09-04 with anaconda and blivet updated, standard partitions.

Version-Release number of selected component:
anaconda-core-23.19.2-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1286, in eintr_retry_call
    return func(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1058, in conditional_chown
    eintr_retry_call(os.chown, path, uid, gid)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1067, in <lambda>
    from_gid_only))
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1015, in dir_tree_map
    func(dir_ent)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1065, in chown_dir_tree
    dir_tree_map(root, lambda path: conditional_chown(path, uid, gid,
  File "/usr/lib64/python3.4/site-packages/pyanaconda/users.py", line 335, in createUser
    orig_uid, orig_gid)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 1742, in execute
    if not users.createUser(usr.name, **kwargs):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 96, in doConfiguration
    ksdata.user.execute(storage, ksdata, instClass, u)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: uid should be integer, not str

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23-2015090 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-1.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Piotr Drąg 2015-09-05 19:38:54 EDT
Created attachment 1070556 [details]
File: anaconda-tb
Comment 2 Piotr Drąg 2015-09-05 19:38:56 EDT
Created attachment 1070557 [details]
File: anaconda.log
Comment 3 Piotr Drąg 2015-09-05 19:38:57 EDT
Created attachment 1070558 [details]
File: environ
Comment 4 Piotr Drąg 2015-09-05 19:39:03 EDT
Created attachment 1070559 [details]
File: journalctl
Comment 5 Piotr Drąg 2015-09-05 19:39:04 EDT
Created attachment 1070560 [details]
File: lsblk_output
Comment 6 Piotr Drąg 2015-09-05 19:39:06 EDT
Created attachment 1070561 [details]
File: nmcli_dev_list
Comment 7 Piotr Drąg 2015-09-05 19:39:07 EDT
Created attachment 1070562 [details]
File: os_info
Comment 8 Piotr Drąg 2015-09-05 19:39:09 EDT
Created attachment 1070563 [details]
File: program.log
Comment 9 Piotr Drąg 2015-09-05 19:39:13 EDT
Created attachment 1070564 [details]
File: storage.log
Comment 10 Piotr Drąg 2015-09-05 19:39:14 EDT
Created attachment 1070565 [details]
File: ifcfg.log
Comment 11 Piotr Drąg 2015-09-05 19:39:16 EDT
Created attachment 1070566 [details]
File: packaging.log
Comment 12 David Shea 2015-09-08 09:48:30 EDT
*** Bug 1260396 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Blocker Bugs Application 2015-09-09 11:03:36 EDT
Proposed as a Blocker for 23-beta by Fedora user dshea using the blocker tracking app because:

 per the statement in the beta criteria, "The requirement 'assign mount points to existing storage volumes' is considered to cover the common operation of re-using an existing /home partition without formatting it. For all other mount points, it is acceptable if re-use requires them to be re-formatted. "
Comment 14 David Shea 2015-09-10 10:16:54 EDT
*** Bug 1261072 has been marked as a duplicate of this bug. ***
Comment 15 Adam Williamson 2015-09-10 15:15:12 EDT
Discussed at 2015-09-10 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . Accepted as a blocker. This bug happens when you re-use an existing /home partition and create a user account who has a home directory on that partition: anaconda helpfully tries to ensure the SELinux contexts and ownership are correct, and crashes in doing so.

Thus this is technically a conditional violation - it only happens if you create a user account that 'matches' the existing /home - but we felt this is, if anything, going to be the most likely scenario, so the impact is sufficiently broad to constitute a blocker bug.
Comment 16 John Dulaney 2015-09-11 00:54:44 EDT
Another user experienced a similar problem:

Blew up during create user stage of installation

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-23_B_T4-x86_64 quiet
hashmarkername: anaconda
kernel:         4.2.0-1.fc23.x86_64
package:        anaconda-23.19.2-1
product:        Fedora
reason:         TypeError: uid should be integer, not str
release:        Cannot get release name.
version:        23
Comment 17 Leslie Satenstein 2015-09-12 09:31:02 EDT
Another user experienced a similar problem:

Unknown Error has occurred.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-23_B_T5-x86_64 quiet
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
package:        anaconda-23.19.3-1
product:        Fedora
reason:         TypeError: uid should be integer, not str
release:        Cannot get release name.
version:        23
Comment 18 Richard Ryniker 2015-09-12 13:53:46 EDT
Another user experienced a similar problem:

F23 beta TC5 live workstation:  install to hard drive, specify standard partitions.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23_B-T5 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.3-1.fc23.x86_64
product:        Fedora
reason:         TypeError: uid should be integer, not str
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 19 Severin Gehwolf 2015-09-14 06:02:07 EDT
Another user experienced a similar problem:

Specify a custom UID for the user being created via the anaconda installer.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23_B-T4 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-1.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.2-1.fc23.x86_64
product:        Fedora
reason:         TypeError: uid should be integer, not str
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 20 Fedora Update System 2015-09-14 13:21:55 EDT
python-blivet-1.12.4-1.fc23 anaconda-23.19.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846
Comment 21 Fedora Update System 2015-09-15 12:50:47 EDT
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846
Comment 22 Fedora Update System 2015-09-16 14:35:44 EDT
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.