Bug 1260396 - TypeError: uid should be integer, not str
TypeError: uid should be integer, not str
Status: CLOSED DUPLICATE of bug 1260318
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:71ba50b06bb7b6a4ab4c4be298e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 08:03 EDT by Nicolas Mailhot
Modified: 2015-09-08 09:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 09:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.62 MB, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: anaconda.log (148.55 KB, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: dnf.log (34.59 KB, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: dnf.rpm.log (35.83 KB, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: environ (459 bytes, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: lsblk_output (4.84 KB, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: nmcli_dev_list (2.25 KB, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: os_info (451 bytes, text/plain)
2015-09-06 08:03 EDT, Nicolas Mailhot
no flags Details
File: storage.log (928.28 KB, text/plain)
2015-09-06 08:04 EDT, Nicolas Mailhot
no flags Details
File: syslog (138.27 KB, text/plain)
2015-09-06 08:04 EDT, Nicolas Mailhot
no flags Details
File: ifcfg.log (5.95 KB, text/plain)
2015-09-06 08:04 EDT, Nicolas Mailhot
no flags Details
File: packaging.log (1.78 KB, text/plain)
2015-09-06 08:04 EDT, Nicolas Mailhot
no flags Details
File: program.log (169.28 KB, application/octet-stream)
2015-09-06 08:04 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2015-09-06 08:03:26 EDT
Description of problem:
At user creation phase in anaconda

Version-Release number of selected component:
anaconda-24.1-1

The following was filed automatically by anaconda:
anaconda 24.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1286, in eintr_retry_call
    return func(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1058, in conditional_chown
    eintr_retry_call(os.chown, path, uid, gid)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1067, in <lambda>
    from_gid_only))
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1015, in dir_tree_map
    func(dir_ent)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 1065, in chown_dir_tree
    dir_tree_map(root, lambda path: conditional_chown(path, uid, gid,
  File "/usr/lib64/python3.4/site-packages/pyanaconda/users.py", line 335, in createUser
    orig_uid, orig_gid)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 1741, in execute
    if not users.createUser(usr.name, **kwargs):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 96, in doConfiguration
    ksdata.user.execute(storage, ksdata, instClass, u)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: uid should be integer, not str

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-1.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        Rawhide

Potential duplicate: bug 1260318
Comment 1 Nicolas Mailhot 2015-09-06 08:03:46 EDT
Created attachment 1070723 [details]
File: anaconda-tb
Comment 2 Nicolas Mailhot 2015-09-06 08:03:49 EDT
Created attachment 1070724 [details]
File: anaconda.log
Comment 3 Nicolas Mailhot 2015-09-06 08:03:50 EDT
Created attachment 1070725 [details]
File: dnf.log
Comment 4 Nicolas Mailhot 2015-09-06 08:03:52 EDT
Created attachment 1070726 [details]
File: dnf.rpm.log
Comment 5 Nicolas Mailhot 2015-09-06 08:03:53 EDT
Created attachment 1070727 [details]
File: environ
Comment 6 Nicolas Mailhot 2015-09-06 08:03:55 EDT
Created attachment 1070728 [details]
File: lsblk_output
Comment 7 Nicolas Mailhot 2015-09-06 08:03:56 EDT
Created attachment 1070729 [details]
File: nmcli_dev_list
Comment 8 Nicolas Mailhot 2015-09-06 08:03:57 EDT
Created attachment 1070730 [details]
File: os_info
Comment 9 Nicolas Mailhot 2015-09-06 08:04:08 EDT
Created attachment 1070731 [details]
File: storage.log
Comment 10 Nicolas Mailhot 2015-09-06 08:04:11 EDT
Created attachment 1070732 [details]
File: syslog
Comment 11 Nicolas Mailhot 2015-09-06 08:04:12 EDT
Created attachment 1070733 [details]
File: ifcfg.log
Comment 12 Nicolas Mailhot 2015-09-06 08:04:13 EDT
Created attachment 1070734 [details]
File: packaging.log
Comment 13 Nicolas Mailhot 2015-09-06 08:04:16 EDT
Created attachment 1070735 [details]
File: program.log
Comment 14 David Shea 2015-09-08 09:48:29 EDT

*** This bug has been marked as a duplicate of bug 1260318 ***

Note You need to log in before you can comment on or make changes to this bug.